# CVE-2025-67490: Auth0 Next.js SDK has Improper Request Caching Lookup

> Simultaneous requests may cause improper token cache lookups, potentially exposing user data or enabling account takeover in Next.js applications.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-wcgj-f865-c7j7

## What is CVE-2025-67490?

CVE-2025-67490 is a medium-severity vulnerability in nextjs-auth0, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-67490?

4 open source packages ship an affected version, including @auth0/nextjs-auth0. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@auth0/nextjs-auth0` | npm | From 4.11.0 | 4.11.2 |
| `@auth0/nextjs-auth0` | npm | From 4.11.0 | 4.11.2 |
| `@auth0/nextjs-auth0` | npm | From 4.12.0 | 4.12.1 |
| `@auth0/nextjs-auth0` | npm | From 4.12.0 | 4.12.1 |

Products: Auth0 Nextjs-Auth0.

## How do I fix CVE-2025-67490?

Upgrade @auth0/nextjs-auth0 to a fixed version for your release line: 4.11.2 or 4.12.1.

## Is CVE-2025-67490 being exploited?

There is no known exploitation of CVE-2025-67490 in the wild and no public exploit code.

## Other vulnerabilities in nextjs-auth0

- [CVE-2021-32702](https://insights.sbomify.com/CVE-2021-32702/): Reflected XSS from the callback handler's error query parameter (high 8.0)
- [CVE-2021-43812](https://insights.sbomify.com/CVE-2021-43812/): Open redirect in nextjs-auth0 (medium 6.4)
- [CVE-2025-67716](https://insights.sbomify.com/CVE-2025-67716/): Auth0 Next.js SDK has Improper Validation of Query Parameters (medium 5.7)
- [CVE-2026-40155](https://insights.sbomify.com/CVE-2026-40155/): Auth0 Next.js SDK has Improper Proxy Cache Lookup (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67490 and fix it if it is affected.

What it is: CVE-2025-67490 is a medium-severity vulnerability in nextjs-auth0, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67490 in the wild and no public exploit code.

Affected packages and fixed versions:
- @auth0/nextjs-auth0 (npm): affected from 4.11.0; fixed in 4.11.2
- @auth0/nextjs-auth0 (npm): affected from 4.11.0; fixed in 4.11.2
- @auth0/nextjs-auth0 (npm): affected from 4.12.0; fixed in 4.12.1
- @auth0/nextjs-auth0 (npm): affected from 4.12.0; fixed in 4.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67490/ (Markdown: https://insights.sbomify.com/CVE-2025-67490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67490
- OSV: https://osv.dev/vulnerability/CVE-2025-67490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67490/
Summaries are generated and may contain mistakes; the official description above is the record.
