CVE-2025-67499 CNI Plugins Portmap nftables backend intercepts non-local traffic
Containers can intercept all traffic destined for a specific port on the host when the nftables backend is used, exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-67499?
CVE-2025-67499 is a medium-severity vulnerability in containernetworking plugins, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The CNI portmap plugin allows containers to emulate opening a host port, forwarding that traffic to the container. Versions 1.6.0 through 1.8.0 inadvertently forward all traffic with the same destination port as the host port when the portmap plugin is configured with the nftables backend, thus ignoring the destination IP. This includes traffic not intended for the node itself, i.e. traffic to containers hosted on the node. Containers that request HostPort forwarding can intercept all traffic destined for that port. This requires that the portmap plugin be explicitly configured to use the nftables backend. This issue is fixed in version 1.9.0. To workaround, configure the portmap plugin to use the iptables backend. It does not have this vulnerability.
Weakness: CWE-200
Which versions are affected by CVE-2025-67499?
3 open source packages ship an affected version, including github.com/containernetworking/plugins. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containernetworking/plugins Go | From 1.6.0 | 1.9.0 |
github.com/containernetworking/plugins Go | From 1.6.0 | 1.9.0 |
github.com/containernetworking/plugins Go | From 1.6.0 | 1.9.0 |
Linux distribution packages (1)
docker openSUSE:Tumbleweed | All versions | 29.2.1_ce-37.1 |
Products include Linuxfoundation Cni Network Plugins.
How do I fix CVE-2025-67499?
Upgrade github.com/containernetworking/plugins to 1.9.0 or later.
Is CVE-2025-67499 being exploited?
There is no known exploitation of CVE-2025-67499 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-CX03241, CLEANSTART-2026-GU03381, CLEANSTART-2026-NW65912, CLEANSTART-2026-SJ63169, GHSA-jv3w-x3r3-g6rm, GO-2025-4222 and 23 more.