# CVE-2025-67499: CNI Plugins Portmap nftables backend intercepts non-local traffic

> Containers can intercept all traffic destined for a specific port on the host when the nftables backend is used, exposing sensitive data.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 10 Dec 2025
- **Also known as:** CLEANSTART-2026-CX03241, CLEANSTART-2026-GU03381, CLEANSTART-2026-NW65912, CLEANSTART-2026-SJ63169, GHSA-jv3w-x3r3-g6rm, GO-2025-4222, MINI-2fmx-rpvm-r998, MINI-43px-j8h6-764c, MINI-4fjx-mg5q-fc69, MINI-4jr7-6428-4cg5, MINI-62xp-qm44-f22m, MINI-6vgm-8v79-3gc2, MINI-7mpp-p5rw-p66r, MINI-7r22-2x6g-8vgj, MINI-7vp7-5h98-cfjp, MINI-85cc-vr4c-9fc7, MINI-85x2-mc7g-c4w7, MINI-95w3-vrm5-gjfp, MINI-9cc9-gw6m-c4hf, MINI-9mrx-257j-8fg7, MINI-c28q-9658-3m54, MINI-fjf3-69v7-3cxh, MINI-m6cq-2xph-4vhg, MINI-mvmc-r869-5rvr, MINI-q586-4fq7-25fj, MINI-rghw-62c4-6gxq, MINI-wgpc-37gm-5vcf, UBUNTU-CVE-2025-67499, openSUSE-SU-2026:10261-1

## What is CVE-2025-67499?

CVE-2025-67499 is a medium-severity vulnerability in containernetworking plugins, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The CNI portmap plugin allows containers to emulate opening a host port, forwarding that traffic to the container. Versions 1.6.0 through 1.8.0  inadvertently forward all traffic with the same destination port as the host port when the portmap plugin is configured with the nftables backend, thus ignoring the destination IP. This includes traffic not intended for the node itself, i.e. traffic to containers hosted on the node. Containers that request HostPort forwarding can intercept all traffic destined for that port. This requires that the portmap plugin be explicitly configured to use the nftables backend. This issue is fixed in version 1.9.0. To workaround, configure the portmap plugin to use the iptables backend. It does not have this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-67499?

3 open source packages ship an affected version, including github.com/containernetworking/plugins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containernetworking/plugins` | Go | From 1.6.0 | 1.9.0 |
| `github.com/containernetworking/plugins` | Go | From 1.6.0 | 1.9.0 |
| `github.com/containernetworking/plugins` | Go | From 1.6.0 | 1.9.0 |
| `docker` | openSUSE:Tumbleweed | All versions | 29.2.1_ce-37.1 |

Products: Linuxfoundation Cni Network Plugins.

## How do I fix CVE-2025-67499?

Upgrade github.com/containernetworking/plugins to 1.9.0 or later.

## Is CVE-2025-67499 being exploited?

There is no known exploitation of CVE-2025-67499 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67499 and fix it if it is affected.

What it is: CVE-2025-67499 is a medium-severity vulnerability in containernetworking plugins, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67499 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containernetworking/plugins (Go): affected from 1.6.0; fixed in 1.9.0
- github.com/containernetworking/plugins (Go): affected from 1.6.0; fixed in 1.9.0
- github.com/containernetworking/plugins (Go): affected from 1.6.0; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67499/ (Markdown: https://insights.sbomify.com/CVE-2025-67499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67499
- OSV: https://osv.dev/vulnerability/CVE-2025-67499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67499/
Summaries are generated and may contain mistakes; the official description above is the record.
