# CVE-2025-67505: Race condition in the Okta Java SDK

> Concurrent API requests in the Okta Java SDK may mix response data, potentially exposing or altering information across different user sessions.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-j5gq-897m-2rff

## What is CVE-2025-67505?

CVE-2025-67505 is a high-severity vulnerability in okta-sdk-java, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Okta Java Management SDK facilitates interactions with the Okta management API. In versions 11.0.0 through 20.0.0, race conditions may arise from concurrent requests using the ApiClient class. This could cause a status code or response header from one request’s response to influence another request’s response. This issue is fixed in version 20.0.1.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2025-67505?

2 open source packages ship an affected version, including com.okta.sdk:okta-sdk-root. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.okta.sdk:okta-sdk-root` | Maven | From 11.0.0 | 20.0.1 |
| `com.okta.sdk:okta-sdk-root` | Maven | From 11.0.0 | 20.0.1 |

Products: Okta Java Management Sdk.

## How do I fix CVE-2025-67505?

Upgrade com.okta.sdk:okta-sdk-root to 20.0.1 or later.

## Is CVE-2025-67505 being exploited?

There is no known exploitation of CVE-2025-67505 in the wild and no public exploit code.

## Other vulnerabilities in okta-sdk-java

- [CVE-2025-66033](https://insights.sbomify.com/CVE-2025-66033/): Improper Memory Cleanup in the Okta Java SDK (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67505 and fix it if it is affected.

What it is: CVE-2025-67505 is a high-severity vulnerability in okta-sdk-java, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67505 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.okta.sdk:okta-sdk-root (Maven): affected from 11.0.0; fixed in 20.0.1
- com.okta.sdk:okta-sdk-root (Maven): affected from 11.0.0; fixed in 20.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67505/ (Markdown: https://insights.sbomify.com/CVE-2025-67505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67505
- OSV: https://osv.dev/vulnerability/CVE-2025-67505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67505/
Summaries are generated and may contain mistakes; the official description above is the record.
