CVE-2025-67507 Filament's multi-factor authentication (app) recovery codes can be used multiple times

High 8.1 Published Updated

Attackers can reuse MFA recovery codes indefinitely to bypass authentication and take over accounts in Filament applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-67507?

CVE-2025-67507 is a high-severity authentication bypass vulnerability in filamentphp filament, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.3.0 contain a flaw in the handling of recovery codes for app-based multi-factor authentication, allowing the same recovery code to be reused indefinitely. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. This issue is fixed in version 4.3.1.

Weakness: CWE-288, CWE-287

Which versions are affected by CVE-2025-67507?

2 open source packages ship an affected version, including filament/filament. It affects 1 product.

PackageAffectedFixed in
filament/filament PackagistFrom 4.0.04.3.1
filament/filament PackagistFrom 4.0.04.3.1

Products include Filamentphp Filament.

How do I fix CVE-2025-67507?

Upgrade filament/filament to 4.3.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-67507 being exploited?

There is no known exploitation of CVE-2025-67507 in the wild and no public exploit code.

Sources

Also known as GHSA-pvcv-q3q7-266g.

Is CVE-2025-67507 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free