{"answers":{"affected":"2 open source packages ship an affected version, including filament/filament. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-67507 in the wild and no public exploit code.","fix":"Upgrade filament/filament to 4.3.1 or later.","what":"CVE-2025-67507 is a high-severity authentication bypass vulnerability in filamentphp filament, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-67507 and fix it if it is affected.\n\nWhat it is: CVE-2025-67507 is a high-severity authentication bypass vulnerability in filamentphp filament, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-67507 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- filament/filament (Packagist): affected from 4.0.0; fixed in 4.3.1\n- filament/filament (Packagist): affected from 4.0.0; fixed in 4.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67507/ (Markdown: https://insights.sbomify.com/CVE-2025-67507/index.md)","id":"CVE-2025-67507","markdown":"https://insights.sbomify.com/CVE-2025-67507/index.md","name":"CVE-2025-67507","record":{"aliases":["GHSA-pvcv-q3q7-266g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Laravel development library","requires_auth":"none","summary":"Attackers can reuse MFA recovery codes indefinitely to bypass authentication and take over accounts in Filament applications.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"filament","vendor":"filamentphp"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.3.0 contain a flaw in the handling of recovery codes for app-based multi-factor authentication, allowing the same recovery code to be reused indefinitely. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. This issue is fixed in version 4.3.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Filament's multi-factor authentication (app) recovery codes can be used multiple times","id":"CVE-2025-67507","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"gardenctl is vulnerable to Command Injection when used with non‑POSIX shells","id":"CVE-2025-67508"},"packages":[{"ecosystem":"Packagist","fixed":["4.3.1"],"introduced":["4.0.0"],"last_affected":[],"package":"filament/filament","purl":null,"source":"GHSA-pvcv-q3q7-266g"},{"ecosystem":"Packagist","fixed":["4.3.1"],"introduced":["4.0.0"],"last_affected":[],"package":"filament/filament","purl":"pkg:composer/filament/filament","source":"GHSA-pvcv-q3q7-266g"}],"prev":{"headline":"PipesHub Vulnerable to Path Traversal through Unauthenticated Arbitrary File Upload","id":"CVE-2025-67506"},"products":["filament"],"published":"2025-12-10","related":[{"cvss_score":7.3,"headline":"Filament: Unvalidated Range and Values summarizer values can be used for XSS","id":"CVE-2026-33080","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":6.1,"headline":"Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting","id":"CVE-2024-47186","kev_date_added":null,"published":"2024-09-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-10","vendors":["filamentphp"]},"summary":"Attackers can reuse MFA recovery codes indefinitely to bypass authentication and take over accounts in Filament applications.","url":"https://insights.sbomify.com/CVE-2025-67507/"}