# CVE-2025-67507: Filament's multi-factor authentication (app) recovery codes can be used multiple times

> Attackers can reuse MFA recovery codes indefinitely to bypass authentication and take over accounts in Filament applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 10 Dec 2025
- **Also known as:** GHSA-pvcv-q3q7-266g

## What is CVE-2025-67507?

CVE-2025-67507 is a high-severity authentication bypass vulnerability in filamentphp filament, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.3.0 contain a flaw in the handling of recovery codes for app-based multi-factor authentication, allowing the same recovery code to be reused indefinitely. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. This issue is fixed in version 4.3.1.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-67507?

2 open source packages ship an affected version, including filament/filament. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `filament/filament` | Packagist | From 4.0.0 | 4.3.1 |
| `filament/filament` | Packagist | From 4.0.0 | 4.3.1 |

Products: Filamentphp Filament.

## How do I fix CVE-2025-67507?

Upgrade filament/filament to 4.3.1 or later.

## Is CVE-2025-67507 being exploited?

There is no known exploitation of CVE-2025-67507 in the wild and no public exploit code.

## Other vulnerabilities in filamentphp filament

- [CVE-2026-33080](https://insights.sbomify.com/CVE-2026-33080/): Filament: Unvalidated Range and Values summarizer values can be used for XSS (high 7.3)
- [CVE-2024-47186](https://insights.sbomify.com/CVE-2024-47186/): Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67507 and fix it if it is affected.

What it is: CVE-2025-67507 is a high-severity authentication bypass vulnerability in filamentphp filament, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67507 in the wild and no public exploit code.

Affected packages and fixed versions:
- filament/filament (Packagist): affected from 4.0.0; fixed in 4.3.1
- filament/filament (Packagist): affected from 4.0.0; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67507/ (Markdown: https://insights.sbomify.com/CVE-2025-67507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67507
- OSV: https://osv.dev/vulnerability/CVE-2025-67507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67507/
Summaries are generated and may contain mistakes; the official description above is the record.
