CVE-2025-67508 gardenctl is vulnerable to Command Injection when used with non‑POSIX shells
Attackers with project admin rights can execute arbitrary commands on operator machines using non-POSIX shells via malicious credential values.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67508?
CVE-2025-67508 is a high-severity command injection vulnerability in gardener gardenctl-v2, published on 12 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
gardenctl is a command-line client for the Gardener which configures access to clusters and cloud provider CLI tools. When using non‑POSIX shells such as Fish and PowerShell, versions 2.11.0 and below of gardenctl allow an attacker with administrative privileges for a Gardener project to craft malicious credential values. The forged credential values are used in infrastructure Secret objects that break out of the intended string context when evaluated in Fish or PowerShell environments used by the Gardener service operators. This issue is fixed in version 2.12.0.
Weakness: CWE-77
Which versions are affected by CVE-2025-67508?
3 open source packages ship an affected version, including github.com/gardener/gardenctl-v2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/gardener/gardenctl-v2 Go | All versions | 0.0.0-20251107111549-0bdc484cb5fb |
github.com/gardener/gardenctl-v2 Go | All versions | 0.0.0-20251107111549-0bdc484cb5fb |
github.com/gardener/gardenctl-v2 Go | All versions | 0.0.0-20251107111549-0bdc484cb5fb |
Products include Linuxfoundation Gardenctl.
How do I fix CVE-2025-67508?
Upgrade github.com/gardener/gardenctl-v2 to 0.0.0-20251107111549-0bdc484cb5fb or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2025-67508 being exploited?
There is no known exploitation of CVE-2025-67508 in the wild and no public exploit code.
Sources
Also known as GHSA-fw33-qpx7-rhx2, GO-2025-4232.