# CVE-2025-67508: gardenctl is vulnerable to Command Injection when used with non‑POSIX shells

> Attackers with project admin rights can execute arbitrary commands on operator machines using non-POSIX shells via malicious credential values.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** GHSA-fw33-qpx7-rhx2, GO-2025-4232

## What is CVE-2025-67508?

CVE-2025-67508 is a high-severity command injection vulnerability in gardener gardenctl-v2, published on 12 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

gardenctl is a command-line client for the Gardener which configures access to clusters and cloud provider CLI tools. When using non‑POSIX shells such as Fish and PowerShell, versions 2.11.0 and below of gardenctl allow an attacker with administrative privileges for a Gardener project to craft malicious credential values. The forged credential values are used in infrastructure Secret objects that break out of the intended string context when evaluated in Fish or PowerShell environments used by the Gardener service operators. This issue is fixed in version 2.12.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-67508?

3 open source packages ship an affected version, including github.com/gardener/gardenctl-v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gardener/gardenctl-v2` | Go | All versions | 0.0.0-20251107111549-0bdc484cb5fb |
| `github.com/gardener/gardenctl-v2` | Go | All versions | 0.0.0-20251107111549-0bdc484cb5fb |
| `github.com/gardener/gardenctl-v2` | Go | All versions | 0.0.0-20251107111549-0bdc484cb5fb |

Products: Linuxfoundation Gardenctl.

## How do I fix CVE-2025-67508?

Upgrade github.com/gardener/gardenctl-v2 to 0.0.0-20251107111549-0bdc484cb5fb or later.

## Is CVE-2025-67508 being exploited?

There is no known exploitation of CVE-2025-67508 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67508 and fix it if it is affected.

What it is: CVE-2025-67508 is a high-severity command injection vulnerability in gardener gardenctl-v2, published on 12 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67508 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gardener/gardenctl-v2 (Go): affected all versions; fixed in 0.0.0-20251107111549-0bdc484cb5fb
- github.com/gardener/gardenctl-v2 (Go): affected all versions; fixed in 0.0.0-20251107111549-0bdc484cb5fb
- github.com/gardener/gardenctl-v2 (Go): affected all versions; fixed in 0.0.0-20251107111549-0bdc484cb5fb

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67508/ (Markdown: https://insights.sbomify.com/CVE-2025-67508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67508
- OSV: https://osv.dev/vulnerability/CVE-2025-67508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67508/
Summaries are generated and may contain mistakes; the official description above is the record.
