# CVE-2025-67510: MySQLWriteTool allows arbitrary/destructive SQL when exposed to untrusted prompts (agent “footgun”)

> Prompt injection in Neuron AI framework allows attackers to execute destructive SQL queries via the MySQLWriteTool if exposed to untrusted input.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-898v-775g-777c

## What is CVE-2025-67510?

CVE-2025-67510 is a critical SQL injection vulnerability in neuron-core neuron-ai, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Neuron is a PHP framework for creating and orchestrating AI Agents. In versions 2.8.11 and below, the MySQLWriteTool executes arbitrary SQL provided by the caller using PDO::prepare() + execute() without semantic restrictions. This is consistent with the name (“write tool”), but in an LLM/agent context it becomes a high-risk capability: prompt injection or indirect prompt manipulation can cause execution of destructive queries such as DROP TABLE, TRUNCATE, DELETE, ALTER, or privilege-related statements (subject to DB permissions). Deployments that expose an agent with MySQLWriteTool enabled to untrusted input and/or run the tool with a DB user that has broad privileges are impacted. This issue is fixed in version 2.8.12.

Weakness: CWE-284 (Improper Access Control), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2025-67510?

2 open source packages ship an affected version, including neuron-core/neuron-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neuron-core/neuron-ai` | Packagist | All versions | 2.8.12 |
| `neuron-core/neuron-ai` | Packagist | All versions | 2.8.12 |

Products: Neuron-Ai Neuron.

## How do I fix CVE-2025-67510?

Upgrade neuron-core/neuron-ai to 2.8.12 or later.

## Is CVE-2025-67510 being exploited?

There is no known exploitation of CVE-2025-67510 in the wild and no public exploit code.

## Other vulnerabilities in neuron-core neuron-ai

- [CVE-2025-67509](https://insights.sbomify.com/CVE-2025-67509/): MySQLSelectTool Read-Only Bypass via SELECT INTO OUTFILE Allows Arbitrary File Write (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67510 and fix it if it is affected.

What it is: CVE-2025-67510 is a critical SQL injection vulnerability in neuron-core neuron-ai, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67510 in the wild and no public exploit code.

Affected packages and fixed versions:
- neuron-core/neuron-ai (Packagist): affected all versions; fixed in 2.8.12
- neuron-core/neuron-ai (Packagist): affected all versions; fixed in 2.8.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67510/ (Markdown: https://insights.sbomify.com/CVE-2025-67510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67510
- OSV: https://osv.dev/vulnerability/CVE-2025-67510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67510/
Summaries are generated and may contain mistakes; the official description above is the record.
