CVE-2025-67635 Jenkins has a Denial of service vulnerability in HTTP-based CLI
Unauthenticated attackers can cause a denial of service in Jenkins by exploiting improper closure of corrupted HTTP-based CLI connections.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-67635?
CVE-2025-67635 is a high-severity denial of service vulnerability in Jenkins Jenkins, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
Weakness: CWE-404
Which versions are affected by CVE-2025-67635?
9 open source packages ship an affected version, including org.jenkins-ci.main:cli, jenkins and org.jenkins-ci.main:jenkins-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:cli Maven | All versions | 2.528.3 |
org.jenkins-ci.main:cli Maven | All versions | 2.528.3 |
org.jenkins-ci.main:cli Maven | From 2.529 | 2.541 |
org.jenkins-ci.main:cli Maven | From 2.529 | 2.541 |
jenkins Bitnami | All versions | 2.528.3, 2.541.0 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.528.3 |
3 more packages
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.528.3 |
org.jenkins-ci.main:jenkins-core Maven | From 2.529 | 2.541 |
org.jenkins-ci.main:jenkins-core Maven | From 2.529 | 2.541 |
Products include Jenkins Jenkins.
How do I fix CVE-2025-67635?
Upgrade org.jenkins-ci.main:cli to a fixed version for your release line: 2.528.3 or 2.541.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-67635 being exploited?
There is no known exploitation of CVE-2025-67635 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as BIT-jenkins-2025-67635, GHSA-9p56-p6mw-w8qc, MINI-98r9-m4p9-w99p, MINI-ff37-x9qw-wc38, MINI-fqq9-m9wh-4xc5, MINI-g299-v84g-q2cp and 2 more.