# CVE-2025-67639: Jenkins has a CSRF vulnerability on the login form

> Attackers can trick Jenkins users into logging into an attacker-controlled account via CSRF, potentially leading to account takeover.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 10 Dec 2025
- **Also known as:** BIT-jenkins-2025-67639, GHSA-6837-qgrc-x5p6, MINI-9w6q-gpf8-w46q, MINI-c8jf-r43r-vf24, MINI-cw72-77r8-8hr2, MINI-ffcc-wjh4-9m32, MINI-gcww-4fmf-mp82

## What is CVE-2025-67639?

CVE-2025-67639 is a low-severity vulnerability in Jenkins Jenkins, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins 2.540 and earlier, LTS 2.528.2 and earlier allows attackers to trick users into logging in to the attacker's account.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-67639?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.528.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.528.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.529 | 2.541 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.529 | 2.541 |
| `jenkins` | Bitnami | All versions | 2.528.3, 2.541.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2025-67639?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.528.3 or 2.541.

## Is CVE-2025-67639 being exploited?

There is no known exploitation of CVE-2025-67639 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67639 and fix it if it is affected.

What it is: CVE-2025-67639 is a low-severity vulnerability in Jenkins Jenkins, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67639 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.528.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.528.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.529; fixed in 2.541
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.529; fixed in 2.541
- jenkins (Bitnami): affected all versions; fixed in 2.528.3, 2.541.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67639/ (Markdown: https://insights.sbomify.com/CVE-2025-67639/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67639
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67639
- OSV: https://osv.dev/vulnerability/CVE-2025-67639

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67639/
Summaries are generated and may contain mistakes; the official description above is the record.
