# CVE-2025-67640: Jenkins Git client Plugin has an OS command injection vulnerability on agents in Git client Plugin

> Attackers controlling workspace directory names can inject OS commands via unescaped paths in Jenkins Git plugin scripts.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 10 Dec 2025
- **Also known as:** GHSA-v8hg-m323-jvjq

## What is CVE-2025-67640?

CVE-2025-67640 is a medium-severity command injection vulnerability in Jenkins Git client Plugin, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Git client Plugin 6.4.0 and earlier does not not correctly escape the path to the workspace directory as part of an argument in a temporary shell script generated by the plugin, allowing attackers able to control the workspace directory name to inject arbitrary OS commands.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-67640?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:git-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git-client` | Maven | All versions | 6.4.1 |
| `org.jenkins-ci.plugins:git-client` | Maven | All versions | 6.4.1 |

Products: Jenkins Git Client.

## How do I fix CVE-2025-67640?

Upgrade org.jenkins-ci.plugins:git-client to 6.4.1 or later.

## Is CVE-2025-67640 being exploited?

There is no known exploitation of CVE-2025-67640 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Git client Plugin

- [CVE-2019-10392](https://insights.sbomify.com/CVE-2019-10392/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Git Client Plugin (high 8.8)
- [CVE-2022-36881](https://insights.sbomify.com/CVE-2022-36881/): Jenkins Git client plugin 3.11.0 does not perform SSH host key verification (high 8.1)
- [CVE-2026-57282](https://insights.sbomify.com/CVE-2026-57282/): Jenkins Git client Plugin has an OS command injection vulnerability on agents (medium 5.0)
- [CVE-2025-58458](https://insights.sbomify.com/CVE-2025-58458/): Jenkins Git client Plugin file system information disclosure vulnerability (medium 4.3)
- [CVE-2017-1000242](https://insights.sbomify.com/CVE-2017-1000242/): Insecure temporary file usage in Jenkins Git Client Plugin (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67640 and fix it if it is affected.

What it is: CVE-2025-67640 is a medium-severity command injection vulnerability in Jenkins Git client Plugin, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67640 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git-client (Maven): affected all versions; fixed in 6.4.1
- org.jenkins-ci.plugins:git-client (Maven): affected all versions; fixed in 6.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67640/ (Markdown: https://insights.sbomify.com/CVE-2025-67640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67640
- OSV: https://osv.dev/vulnerability/CVE-2025-67640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67640/
Summaries are generated and may contain mistakes; the official description above is the record.
