{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:coverage. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-67641 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:coverage to 2.3056 or later.","what":"CVE-2025-67641 is a high-severity cross-site scripting vulnerability in Jenkins Coverage Plugin, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-67641 and fix it if it is affected.\n\nWhat it is: CVE-2025-67641 is a high-severity cross-site scripting vulnerability in Jenkins Coverage Plugin, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-67641 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:coverage (Maven): affected all versions; fixed in 2.3056\n- io.jenkins.plugins:coverage (Maven): affected all versions; fixed in 2.3056\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67641/ (Markdown: https://insights.sbomify.com/CVE-2025-67641/index.md)","id":"CVE-2025-67641","markdown":"https://insights.sbomify.com/CVE-2025-67641/index.md","name":"CVE-2025-67641","record":{"aliases":["GHSA-v3f3-rf6r-43x5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Coverage Plugin","requires_auth":"low_privilege","summary":"Attackers with Item/Configure permission can inject JavaScript via REST API, leading to stored XSS in Jenkins Coverage Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"coverage","vendor":"jenkins"}],"cvss":{"score":8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Coverage Plugin 2.3054.ve1ff7b_a_a_123b_ and earlier does not validate the configured coverage results ID when creating coverage results, only when submitting the job configuration through the UI, allowing attackers with Item/Configure permission to use a `javascript:` scheme URL as identifier by configuring the job through the REST API, resulting in a stored cross-site scripting (XSS) vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Coverage Plugin has a stored cross-site scripting (XSS) vulnerability","id":"CVE-2025-67641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins HashiCorp Vault Plugin exposes system-scoped Vault credentials","id":"CVE-2025-67642"},"packages":[{"ecosystem":"Maven","fixed":["2.3056"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:coverage","purl":null,"source":"GHSA-v3f3-rf6r-43x5"},{"ecosystem":"Maven","fixed":["2.3056"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:coverage","purl":"pkg:maven/io.jenkins.plugins/coverage","source":"GHSA-v3f3-rf6r-43x5"}],"prev":{"headline":"Jenkins Git client Plugin has an OS command injection vulnerability on agents in Git client Plugin","id":"CVE-2025-67640"},"products":["Jenkins Coverage Plugin"],"published":"2025-12-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-10","vendors":["Jenkins Project"]},"summary":"Attackers with Item/Configure permission can inject JavaScript via REST API, leading to stored XSS in Jenkins Coverage Plugin.","url":"https://insights.sbomify.com/CVE-2025-67641/"}