# CVE-2025-67641: Jenkins Coverage Plugin has a stored cross-site scripting (XSS) vulnerability

> Attackers with Item/Configure permission can inject JavaScript via REST API, leading to stored XSS in Jenkins Coverage Plugin.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 10 Dec 2025
- **Also known as:** GHSA-v3f3-rf6r-43x5

## What is CVE-2025-67641?

CVE-2025-67641 is a high-severity cross-site scripting vulnerability in Jenkins Coverage Plugin, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Coverage Plugin 2.3054.ve1ff7b_a_a_123b_ and earlier does not validate the configured coverage results ID when creating coverage results, only when submitting the job configuration through the UI, allowing attackers with Item/Configure permission to use a `javascript:` scheme URL as identifier by configuring the job through the REST API, resulting in a stored cross-site scripting (XSS) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-67641?

2 open source packages ship an affected version, including io.jenkins.plugins:coverage. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:coverage` | Maven | All versions | 2.3056 |
| `io.jenkins.plugins:coverage` | Maven | All versions | 2.3056 |

Products: Jenkins Coverage.

## How do I fix CVE-2025-67641?

Upgrade io.jenkins.plugins:coverage to 2.3056 or later.

## Is CVE-2025-67641 being exploited?

There is no known exploitation of CVE-2025-67641 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67641 and fix it if it is affected.

What it is: CVE-2025-67641 is a high-severity cross-site scripting vulnerability in Jenkins Coverage Plugin, published on 10 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67641 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:coverage (Maven): affected all versions; fixed in 2.3056
- io.jenkins.plugins:coverage (Maven): affected all versions; fixed in 2.3056

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67641/ (Markdown: https://insights.sbomify.com/CVE-2025-67641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67641
- OSV: https://osv.dev/vulnerability/CVE-2025-67641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67641/
Summaries are generated and may contain mistakes; the official description above is the record.
