CVE-2025-67647 SvelteKit Denial of service and possible SSRF when using prerendering
Attackers can cause denial of service or SSRF in SvelteKit apps using prerendering and specific adapter configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-67647?
CVE-2025-67647 is a high-severity server-side request forgery vulnerability in sveltejs kit, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.
Which versions are affected by CVE-2025-67647?
4 open source packages ship an affected version, including @sveltejs/kit and @sveltejs/adapter-node. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
@sveltejs/kit npm | From 2.19.0 | 2.49.5 |
@sveltejs/kit npm | From 2.19.0 | 2.49.5 |
@sveltejs/adapter-node npm | From 5.4.1 | 5.5.1 |
@sveltejs/adapter-node npm | From 5.4.1 | 5.5.1 |
Products include Svelte Adapter-Node, Svelte Kit.
How do I fix CVE-2025-67647?
Upgrade @sveltejs/kit to 2.49.5 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-67647 being exploited?
There is no known exploitation of CVE-2025-67647 in the wild and no public exploit code.
Other vulnerabilities in sveltejs kit
Sources
Also known as GHSA-j62c-4x62-9r35.