{"answers":{"affected":"4 open source packages ship an affected version, including @sveltejs/kit and @sveltejs/adapter-node. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-67647 in the wild and no public exploit code.","fix":"Upgrade @sveltejs/kit to 2.49.5 or later.","what":"CVE-2025-67647 is a high-severity server-side request forgery vulnerability in sveltejs kit, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-67647 and fix it if it is affected.\n\nWhat it is: CVE-2025-67647 is a high-severity server-side request forgery vulnerability in sveltejs kit, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-67647 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @sveltejs/kit (npm): affected from 2.19.0; fixed in 2.49.5\n- @sveltejs/kit (npm): affected from 2.19.0; fixed in 2.49.5\n- @sveltejs/adapter-node (npm): affected from 5.4.1; fixed in 5.5.1\n- @sveltejs/adapter-node (npm): affected from 5.4.1; fixed in 5.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67647/ (Markdown: https://insights.sbomify.com/CVE-2025-67647/index.md)","id":"CVE-2025-67647","markdown":"https://insights.sbomify.com/CVE-2025-67647/index.md","name":"CVE-2025-67647","record":{"aliases":["GHSA-j62c-4x62-9r35"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"SvelteKit web framework","requires_auth":"none","summary":"Attackers can cause denial of service or SSRF in SvelteKit apps using prerendering and specific adapter configurations.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"adapter-node","vendor":"svelte"},{"product":"kit","vendor":"svelte"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:H/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-248","name":"Uncaught Exception"}],"description":"SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SvelteKit Denial of service and possible SSRF when using prerendering","id":"CVE-2025-67647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page","id":"CVE-2025-67648"},"packages":[{"ecosystem":"npm","fixed":["5.5.1"],"introduced":["5.4.1"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":null,"source":"GHSA-j62c-4x62-9r35"},{"ecosystem":"npm","fixed":["5.5.1"],"introduced":["5.4.1"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":"pkg:npm/%40sveltejs/adapter-node","source":"GHSA-j62c-4x62-9r35"},{"ecosystem":"npm","fixed":["2.49.5"],"introduced":["2.19.0"],"last_affected":[],"package":"@sveltejs/kit","purl":null,"source":"GHSA-j62c-4x62-9r35"},{"ecosystem":"npm","fixed":["2.49.5"],"introduced":["2.19.0"],"last_affected":[],"package":"@sveltejs/kit","purl":"pkg:npm/%40sveltejs/kit","source":"GHSA-j62c-4x62-9r35"}],"prev":{"headline":"TableProgressTracking's missing CSRF protection allows unauthorized state changes","id":"CVE-2025-67646"},"products":["kit"],"published":"2026-01-15","related":[{"cvss_score":7.5,"headline":"Sending a GET or HEAD request with a body crashes SvelteKit","id":"CVE-2024-23641","kev_date_added":null,"published":"2024-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-15","vendors":["sveltejs"]},"summary":"Attackers can cause denial of service or SSRF in SvelteKit apps using prerendering and specific adapter configurations.","url":"https://insights.sbomify.com/CVE-2025-67647/"}