# CVE-2025-67647: SvelteKit Denial of service and possible SSRF when using prerendering

> Attackers can cause denial of service or SSRF in SvelteKit apps using prerendering and specific adapter configurations.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:H/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026
- **Updated:** 15 Jan 2026
- **Also known as:** GHSA-j62c-4x62-9r35

## What is CVE-2025-67647?

CVE-2025-67647 is a high-severity server-side request forgery vulnerability in sveltejs kit, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-67647?

4 open source packages ship an affected version, including @sveltejs/kit and @sveltejs/adapter-node. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | From 2.19.0 | 2.49.5 |
| `@sveltejs/kit` | npm | From 2.19.0 | 2.49.5 |
| `@sveltejs/adapter-node` | npm | From 5.4.1 | 5.5.1 |
| `@sveltejs/adapter-node` | npm | From 5.4.1 | 5.5.1 |

Products: Svelte Adapter-Node, Svelte Kit.

## How do I fix CVE-2025-67647?

Upgrade @sveltejs/kit to 2.49.5 or later.

## Is CVE-2025-67647 being exploited?

There is no known exploitation of CVE-2025-67647 in the wild and no public exploit code.

## Other vulnerabilities in sveltejs kit

- [CVE-2024-23641](https://insights.sbomify.com/CVE-2024-23641/): Sending a GET or HEAD request with a body crashes SvelteKit (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67647 and fix it if it is affected.

What it is: CVE-2025-67647 is a high-severity server-side request forgery vulnerability in sveltejs kit, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67647 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected from 2.19.0; fixed in 2.49.5
- @sveltejs/kit (npm): affected from 2.19.0; fixed in 2.49.5
- @sveltejs/adapter-node (npm): affected from 5.4.1; fixed in 5.5.1
- @sveltejs/adapter-node (npm): affected from 5.4.1; fixed in 5.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67647/ (Markdown: https://insights.sbomify.com/CVE-2025-67647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67647
- OSV: https://osv.dev/vulnerability/CVE-2025-67647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67647/
Summaries are generated and may contain mistakes; the official description above is the record.
