CVE-2025-67648 Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page
Attackers can execute arbitrary scripts in victims' browsers via a reflected XSS vulnerability in the Shopware storefront login page.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67648?
CVE-2025-67648 is a high-severity cross-site scripting vulnerability in Shopware Shopware, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Shopware is an open commerce platform. Versions 6.4.6.0 through 6.6.10.9 and 6.7.0.0 through 6.7.5.0 have a Reflected XSS vulnerability in AuthController.php. A request parameter from the login page URL is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter, waitTime, which lacks proper input validation. This issue is fixed in versions 6.6.10.10 and 6.7.5.1.
Weakness: CWE-79
Which versions are affected by CVE-2025-67648?
8 open source packages ship an affected version, including shopware/shopware and shopware/storefront. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/shopware Packagist | From 6.4.6.0 | 6.6.10.10 |
shopware/shopware Packagist | From 6.4.6.0 | 6.6.10.10 |
shopware/shopware Packagist | From 6.7.0.0 | 6.7.5.1 |
shopware/shopware Packagist | From 6.7.0.0 | 6.7.5.1 |
shopware/storefront Packagist | From 6.4.6.0 | 6.6.10.10 |
shopware/storefront Packagist | From 6.4.6.0 | 6.6.10.10 |
2 more packages
shopware/storefront Packagist | From 6.7.0.0 | 6.7.5.1 |
shopware/storefront Packagist | From 6.7.0.0 | 6.7.5.1 |
Products include Shopware Shopware.
How do I fix CVE-2025-67648?
Upgrade shopware/shopware to a fixed version for your release line: 6.6.10.10 or 6.7.5.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-67648 being exploited?
There is no known exploitation of CVE-2025-67648 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-6w82-v552-wjw2.