# CVE-2025-67648: Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page

> Attackers can execute arbitrary scripts in victims' browsers via a reflected XSS vulnerability in the Shopware storefront login page.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-6w82-v552-wjw2

## What is CVE-2025-67648?

CVE-2025-67648 is a high-severity cross-site scripting vulnerability in Shopware Shopware, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shopware is an open commerce platform. Versions 6.4.6.0 through 6.6.10.9 and 6.7.0.0 through 6.7.5.0 have a Reflected XSS vulnerability in AuthController.php. A request parameter from the login page URL is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter, waitTime, which lacks proper input validation. This issue is fixed in versions 6.6.10.10 and 6.7.5.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-67648?

8 open source packages ship an affected version, including shopware/shopware and shopware/storefront. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | From 6.4.6.0 | 6.6.10.10 |
| `shopware/shopware` | Packagist | From 6.4.6.0 | 6.6.10.10 |
| `shopware/shopware` | Packagist | From 6.7.0.0 | 6.7.5.1 |
| `shopware/shopware` | Packagist | From 6.7.0.0 | 6.7.5.1 |
| `shopware/storefront` | Packagist | From 6.4.6.0 | 6.6.10.10 |
| `shopware/storefront` | Packagist | From 6.4.6.0 | 6.6.10.10 |
| `shopware/storefront` | Packagist | From 6.7.0.0 | 6.7.5.1 |
| `shopware/storefront` | Packagist | From 6.7.0.0 | 6.7.5.1 |

Products: Shopware Shopware.

## How do I fix CVE-2025-67648?

Upgrade shopware/shopware to a fixed version for your release line: 6.6.10.10 or 6.7.5.1.

## Is CVE-2025-67648 being exploited?

There is no known exploitation of CVE-2025-67648 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67648 and fix it if it is affected.

What it is: CVE-2025-67648 is a high-severity cross-site scripting vulnerability in Shopware Shopware, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67648 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected from 6.4.6.0; fixed in 6.6.10.10
- shopware/shopware (Packagist): affected from 6.4.6.0; fixed in 6.6.10.10
- shopware/shopware (Packagist): affected from 6.7.0.0; fixed in 6.7.5.1
- shopware/shopware (Packagist): affected from 6.7.0.0; fixed in 6.7.5.1
- shopware/storefront (Packagist): affected from 6.4.6.0; fixed in 6.6.10.10
- shopware/storefront (Packagist): affected from 6.4.6.0; fixed in 6.6.10.10
- shopware/storefront (Packagist): affected from 6.7.0.0; fixed in 6.7.5.1
- shopware/storefront (Packagist): affected from 6.7.0.0; fixed in 6.7.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67648/ (Markdown: https://insights.sbomify.com/CVE-2025-67648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67648
- OSV: https://osv.dev/vulnerability/CVE-2025-67648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67648/
Summaries are generated and may contain mistakes; the official description above is the record.
