# CVE-2025-67715: Weblate has Systematic User and Project Enumeration via Broken Authorization in REST API (IDOR)

> Attackers can enumerate users and retrieve notification settings via the REST API due to broken authorization checks in Weblate.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2025
- **Updated:** 16 Dec 2025
- **Also known as:** GHSA-3pmh-24wp-xpf4, PYSEC-2025-233

## What is CVE-2025-67715?

CVE-2025-67715 is a medium-severity missing authorization vulnerability in WeblateOrg weblate, published on 16 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weblate is a web based localization tool. In versions prior to 5.15, it was possible to retrieve user notification settings or list all users via API. Version 5.15 fixes the issue.

Weakness: CWE-285 (Improper Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-67715?

3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.15 |
| `weblate` | PyPI | All versions | 5.15 |
| `Weblate` | PyPI | All versions | 5.15 |

Products: Weblate Weblate.

## How do I fix CVE-2025-67715?

Upgrade weblate to 5.15 or later.

## Is CVE-2025-67715 being exploited?

There is no known exploitation of CVE-2025-67715 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67715 and fix it if it is affected.

What it is: CVE-2025-67715 is a medium-severity missing authorization vulnerability in WeblateOrg weblate, published on 16 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67715 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.15
- weblate (PyPI): affected all versions; fixed in 5.15
- Weblate (PyPI): affected all versions; fixed in 5.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67715/ (Markdown: https://insights.sbomify.com/CVE-2025-67715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67715
- OSV: https://osv.dev/vulnerability/CVE-2025-67715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67715/
Summaries are generated and may contain mistakes; the official description above is the record.
