CVE-2025-67716 Auth0 Next.js SDK has Improper Validation of Query Parameters
Attackers can inject unintended OAuth parameters via the returnTo field, potentially causing tokens to be issued with incorrect scopes or claims.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67716?
CVE-2025-67716 is a medium-severity vulnerability in nextjs-auth0, published on 11 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
Weakness: CWE-184
Which versions are affected by CVE-2025-67716?
2 open source packages ship an affected version, including @auth0/nextjs-auth0. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@auth0/nextjs-auth0 npm | From 4.9.0 | 4.13.0 |
@auth0/nextjs-auth0 npm | From 4.9.0 | 4.13.0 |
Products include Auth0 Nextjs-Auth0.
How do I fix CVE-2025-67716?
Upgrade @auth0/nextjs-auth0 to 4.13.0 or later.
Is CVE-2025-67716 being exploited?
There is no known exploitation of CVE-2025-67716 in the wild and no public exploit code.
Other vulnerabilities in nextjs-auth0
Sources
Also known as GHSA-mr6f-h57v-rpj5.