# CVE-2025-67716: Auth0 Next.js SDK has Improper Validation of Query Parameters

> Attackers can inject unintended OAuth parameters via the returnTo field, potentially causing tokens to be issued with incorrect scopes or claims.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-mr6f-h57v-rpj5

## What is CVE-2025-67716?

CVE-2025-67716 is a medium-severity vulnerability in nextjs-auth0, published on 11 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2025-67716?

2 open source packages ship an affected version, including @auth0/nextjs-auth0. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@auth0/nextjs-auth0` | npm | From 4.9.0 | 4.13.0 |
| `@auth0/nextjs-auth0` | npm | From 4.9.0 | 4.13.0 |

Products: Auth0 Nextjs-Auth0.

## How do I fix CVE-2025-67716?

Upgrade @auth0/nextjs-auth0 to 4.13.0 or later.

## Is CVE-2025-67716 being exploited?

There is no known exploitation of CVE-2025-67716 in the wild and no public exploit code.

## Other vulnerabilities in nextjs-auth0

- [CVE-2021-32702](https://insights.sbomify.com/CVE-2021-32702/): Reflected XSS from the callback handler's error query parameter (high 8.0)
- [CVE-2021-43812](https://insights.sbomify.com/CVE-2021-43812/): Open redirect in nextjs-auth0 (medium 6.4)
- [CVE-2026-40155](https://insights.sbomify.com/CVE-2026-40155/): Auth0 Next.js SDK has Improper Proxy Cache Lookup (medium 5.4)
- [CVE-2025-67490](https://insights.sbomify.com/CVE-2025-67490/): Auth0 Next.js SDK has Improper Request Caching Lookup (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67716 and fix it if it is affected.

What it is: CVE-2025-67716 is a medium-severity vulnerability in nextjs-auth0, published on 11 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67716 in the wild and no public exploit code.

Affected packages and fixed versions:
- @auth0/nextjs-auth0 (npm): affected from 4.9.0; fixed in 4.13.0
- @auth0/nextjs-auth0 (npm): affected from 4.9.0; fixed in 4.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67716/ (Markdown: https://insights.sbomify.com/CVE-2025-67716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67716
- OSV: https://osv.dev/vulnerability/CVE-2025-67716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67716/
Summaries are generated and may contain mistakes; the official description above is the record.
