# CVE-2025-67717: Zitadel Discloses the Total Number of Instance Users

> Authenticated users can view the total number of instance users regardless of permissions, potentially exposing sensitive organizational metrics.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-f4cf-9rvr-2rcx, GO-2025-4227

## What is CVE-2025-67717?

CVE-2025-67717 is a medium-severity vulnerability in zitadel, published on 11 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZITADEL is an open-source identity infrastructure tool. Versions 2.44.0 through 3.4.4 and 4.0.0-rc.1 through 4.7.1 disclose the total number of instance users to authenticated users, regardless of their specific permissions. While this does not leak individual user data or PII, disclosing the total user count via the totalResult field constitutes an information disclosure vulnerability that may be sensitive in certain contexts. This issue is fixed in versions 3.4.5 and 4.7.2.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2025-67717?

7 open source packages ship an affected version, including github.com/zitadel/zitadel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251210121356-826039c6208f |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251210121356-826039c6208f |
| `github.com/zitadel/zitadel` | Go | All versions | 1.80.0-v2.20.0.20251210121356-826039c6208f |
| `github.com/zitadel/zitadel` | Go | From 2.44.0 | 3.4.5 |
| `github.com/zitadel/zitadel` | Go | From 2.44.0 | 3.4.5 |
| `github.com/zitadel/zitadel` | Go | From 4.0.0-rc.1 | 4.7.2 |
| `github.com/zitadel/zitadel` | Go | From 4.0.0-rc.1 | 4.7.2 |

Products: Zitadel Zitadel.

## How do I fix CVE-2025-67717?

Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 1.80.0-v2.20.0.20251210121356-826039c6208f, 3.4.5 or 4.7.2.

## Is CVE-2025-67717 being exploited?

There is no known exploitation of CVE-2025-67717 in the wild and no public exploit code.

## Other vulnerabilities in zitadel

- [CVE-2026-29191](https://insights.sbomify.com/CVE-2026-29191/): ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint (critical 9.3)
- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-64103](https://insights.sbomify.com/CVE-2025-64103/): Zitadel Bypass Second Authentication Factor (high 8.7)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67717 and fix it if it is affected.

What it is: CVE-2025-67717 is a medium-severity vulnerability in zitadel, published on 11 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67717 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251210121356-826039c6208f
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251210121356-826039c6208f
- github.com/zitadel/zitadel (Go): affected all versions; fixed in 1.80.0-v2.20.0.20251210121356-826039c6208f
- github.com/zitadel/zitadel (Go): affected from 2.44.0; fixed in 3.4.5
- github.com/zitadel/zitadel (Go): affected from 2.44.0; fixed in 3.4.5
- github.com/zitadel/zitadel (Go): affected from 4.0.0-rc.1; fixed in 4.7.2
- github.com/zitadel/zitadel (Go): affected from 4.0.0-rc.1; fixed in 4.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67717/ (Markdown: https://insights.sbomify.com/CVE-2025-67717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67717
- OSV: https://osv.dev/vulnerability/CVE-2025-67717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67717/
Summaries are generated and may contain mistakes; the official description above is the record.
