# CVE-2025-67718: Formio improperly authorized permission elevation through specially crafted request path

> Attackers can bypass authorization to access protected API endpoints and retrieve sensitive data via crafted request paths in Form.io.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-m654-769v-qjv7

## What is CVE-2025-67718?

CVE-2025-67718 is a high-severity missing authorization vulnerability in formio, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Form.io is a combined Form and API platform for Serverless applications. Versions 3.5.6 and below and 4.0.0-rc.1 through 4.4.2 contain a flaw in path handling which could allow an attacker to access protected API endpoints by sending a crafted request path. An unauthenticated or unauthorized request could retrieve data from endpoints that should be protected. This issue is fixed in versions 3.5.7 and 4.4.3.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2025-67718?

4 open source packages ship an affected version, including formio.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `formio` | npm | All versions | 3.5.7 |
| `formio` | npm | All versions | 3.5.7 |
| `formio` | npm | From 4.0.0-rc.1 | 4.4.3 |
| `formio` | npm | From 4.0.0-rc.1 | 4.4.3 |

## How do I fix CVE-2025-67718?

Upgrade formio to a fixed version for your release line: 3.5.7 or 4.4.3.

## Is CVE-2025-67718 being exploited?

There is no known exploitation of CVE-2025-67718 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67718 and fix it if it is affected.

What it is: CVE-2025-67718 is a high-severity missing authorization vulnerability in formio, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67718 in the wild and no public exploit code.

Affected packages and fixed versions:
- formio (npm): affected all versions; fixed in 3.5.7
- formio (npm): affected all versions; fixed in 3.5.7
- formio (npm): affected from 4.0.0-rc.1; fixed in 4.4.3
- formio (npm): affected from 4.0.0-rc.1; fixed in 4.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67718/ (Markdown: https://insights.sbomify.com/CVE-2025-67718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67718
- OSV: https://osv.dev/vulnerability/CVE-2025-67718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67718/
Summaries are generated and may contain mistakes; the official description above is the record.
