# CVE-2025-67719: Ibexa User Bundle is missing password change validation

> Attackers with unattended access can change user passwords without knowing the current one, leading to account takeover.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-x93p-w2ch-fg67

## What is CVE-2025-67719?

CVE-2025-67719 is a high-severity authentication bypass vulnerability in ibexa user, published on 11 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Ibexa is a composable end-to-end DXP (Digital Experience Platform). Versions 5.0.0-beta1 through 5.0.3 do not have password validation. During the transition from v4 to v5 an error was introduced into validation code which causes the validation of the previous password not to run as expected. This makes it possible for a logged in user to change their password in the back office without knowing the previous password. For example, if a user logs into their account and walks away without locking their workstation, an attacker could access the unattended session and change the password, therefore locking the legitimate user out. This issue is fixed in version 5.0.4.

Weakness: CWE-620 (Unverified Password Change)

## Which versions are affected by CVE-2025-67719?

2 open source packages ship an affected version, including ibexa/user.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ibexa/user` | Packagist | From 5.0.0-beta1 | 5.0.4 |
| `ibexa/user` | Packagist | From 5.0.0-beta1 | 5.0.4 |

## How do I fix CVE-2025-67719?

Upgrade ibexa/user to 5.0.4 or later.

## Is CVE-2025-67719 being exploited?

There is no known exploitation of CVE-2025-67719 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67719 and fix it if it is affected.

What it is: CVE-2025-67719 is a high-severity authentication bypass vulnerability in ibexa user, published on 11 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67719 in the wild and no public exploit code.

Affected packages and fixed versions:
- ibexa/user (Packagist): affected from 5.0.0-beta1; fixed in 5.0.4
- ibexa/user (Packagist): affected from 5.0.0-beta1; fixed in 5.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67719/ (Markdown: https://insights.sbomify.com/CVE-2025-67719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67719
- OSV: https://osv.dev/vulnerability/CVE-2025-67719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67719/
Summaries are generated and may contain mistakes; the official description above is the record.
