# CVE-2025-67721: Aircompressor's Snappy and LZ4 Java-based decompressor implementation can leak information from reused output buffer

> Remote attackers can leak sensitive data from reused output buffers in Aircompressor's Snappy and LZ4 decompressors via crafted compressed input.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 15 Dec 2025
- **Also known as:** CLEANSTART-2026-GC04122, CLEANSTART-2026-SD37188, CLSA-2026-1775521829, CLSA-2026-1791306781, CLSA-2026-1792010896, CLSA-2026-1793127929, ECHO-b2ee-bb66-f00f, GHSA-vx9q-rhv9-3jvg, MINI-2v38-gwmp-r23f, MINI-588w-xxxg-q773, MINI-5c4c-6wpw-v8wj, MINI-8232-fx4q-2m4p, MINI-8853-c7h7-v9v5, MINI-fmxg-r2q6-g3wx, MINI-gcrm-rhcv-6gq6, MINI-gvcr-xhm7-h95m, MINI-jgqj-9cj3-9gv7, MINI-jhwm-9fvq-p26x, MINI-v6qx-qhq4-3hxr, MINI-vgjv-229q-fh7v, MINI-vwv7-qh79-hw43, RHLW-2026-a9a544137749200c

## What is CVE-2025-67721?

CVE-2025-67721 is a medium-severity vulnerability in airlift aircompressor, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Aircompressor is a library with ports of the Snappy, LZO, LZ4, and Zstandard compression algorithms to Java. In versions 3.3 and below, incorrect handling of malformed data in Java-based decompressor implementations for Snappy and LZ4 allow remote attackers to read previous buffer contents via crafted compressed input. With certain crafted compressed inputs, elements from the output buffer can end up in the uncompressed output, potentially leaking sensitive data. This is relevant for applications that reuse the same output buffer to uncompress multiple inputs. This can be the case of a web server that allocates a fix-sized buffer for performance purposes. There is similar vulnerability in GHSA-cmp6-m4wj-q63q. This issue is fixed in version 3.4.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-67721?

4 open source packages ship an affected version, including io.airlift:aircompressor and io.airlift:aircompressor-v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.airlift:aircompressor` | Maven | All versions | 2.0.3 |
| `io.airlift:aircompressor` | Maven | All versions | 2.0.3 |
| `io.airlift:aircompressor-v3` | Maven | All versions | 3.4 |
| `io.airlift:aircompressor-v3` | Maven | All versions | 3.4 |

Products: Airlift Aircompressor.

## How do I fix CVE-2025-67721?

Upgrade io.airlift:aircompressor to 2.0.3 or later.

## Is CVE-2025-67721 being exploited?

There is no known exploitation of CVE-2025-67721 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67721 and fix it if it is affected.

What it is: CVE-2025-67721 is a medium-severity vulnerability in airlift aircompressor, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67721 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.airlift:aircompressor (Maven): affected all versions; fixed in 2.0.3
- io.airlift:aircompressor (Maven): affected all versions; fixed in 2.0.3
- io.airlift:aircompressor-v3 (Maven): affected all versions; fixed in 3.4
- io.airlift:aircompressor-v3 (Maven): affected all versions; fixed in 3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67721/ (Markdown: https://insights.sbomify.com/CVE-2025-67721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67721
- OSV: https://osv.dev/vulnerability/CVE-2025-67721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67721/
Summaries are generated and may contain mistakes; the official description above is the record.
