# CVE-2025-67724: Tornado vulnerable to Header Injection and XSS via reason argument

> Attackers can inject malicious scripts or headers via the reason argument in Tornado, leading to XSS or header injection.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** AZL-72371, AZL-72377, BELL-CVE-2025-67724, DEBIAN-CVE-2025-67724, ECHO-1f27-0b91-adc0, GHSA-pr2v-jx2c-wg9f, MINI-m4j3-6qcf-hmmh, MINI-rgfv-947c-j7h2, PYSEC-2025-265, SUSE-SU-2026:0838-1, UBUNTU-CVE-2025-67724

## What is CVE-2025-67724?

CVE-2025-67724 is a medium-severity cross-site scripting vulnerability in tornadoweb tornado, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Tornado is a Python web framework and asynchronous networking library. In versions 6.5.2 and below, the supplied reason phrase is used unescaped in HTTP headers (where it could be used for header injection) or in HTML in the default error page (where it could be used for XSS) and can be exploited by passing untrusted or malicious data into the reason argument. Used by both RequestHandler.set_status and tornado.web.HTTPError, the argument is designed to allow applications to pass custom "reason" phrases (the "Not Found" in HTTP/1.1 404 Not Found) to the HTTP status line (mainly for non-standard status codes). This issue is fixed in version 6.5.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-644 (Improper Neutralization of HTTP Headers for Scripting Syntax)

## Which versions are affected by CVE-2025-67724?

3 open source packages ship an affected version, including tornado. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.5.3 |
| `tornado` | PyPI | All versions | 6.5.3 |
| `tornado` | PyPI | All versions | 6.5.3 |
| `python-tornado` | SUSE:Linux Enterprise Micro 5.2 | All versions | 4.5.3-150000.3.16.1 |
| `python-tornado` | SUSE:Linux Enterprise Micro 5.3 | All versions | 4.5.3-150000.3.16.1 |
| `python-tornado` | SUSE:Linux Enterprise Micro 5.4 | All versions | 4.5.3-150000.3.16.1 |
| `python-tornado` | SUSE:Linux Enterprise Micro 5.5 | All versions | 4.5.3-150000.3.16.1 |
| `python-tornado` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 4.5.3-150000.3.16.1 |

Products: Tornadoweb Tornado.

## How do I fix CVE-2025-67724?

Upgrade tornado to 6.5.3 or later.

## Is CVE-2025-67724 being exploited?

There is no known exploitation of CVE-2025-67724 in the wild and no public exploit code.

## Other vulnerabilities in tornadoweb tornado

- [CVE-2026-31958](https://insights.sbomify.com/CVE-2026-31958/): Tornado has a DoS due to too many multipart parts (high 8.7)
- [CVE-2025-67725](https://insights.sbomify.com/CVE-2025-67725/): Tornado is Vulnerable to Quadratic DoS via Repeated Header Coalescing (high 7.5)
- [CVE-2025-67726](https://insights.sbomify.com/CVE-2025-67726/): Tornado is Vulnerable to Quadratic DoS via Crafted Multipart Parameters (high 7.5)
- [CVE-2024-52804](https://insights.sbomify.com/CVE-2024-52804/): Tornado has HTTP cookie parsing DoS vulnerability (high 7.5)
- [CVE-2026-35536](https://insights.sbomify.com/CVE-2026-35536/): Tornado has incomplete validation of cookie attributes (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67724 and fix it if it is affected.

What it is: CVE-2025-67724 is a medium-severity cross-site scripting vulnerability in tornadoweb tornado, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-67724 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.5.3
- tornado (PyPI): affected all versions; fixed in 6.5.3
- tornado (PyPI): affected all versions; fixed in 6.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67724/ (Markdown: https://insights.sbomify.com/CVE-2025-67724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67724
- OSV: https://osv.dev/vulnerability/CVE-2025-67724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67724/
Summaries are generated and may contain mistakes; the official description above is the record.
