# CVE-2025-67725: Tornado is Vulnerable to Quadratic DoS via Repeated Header Coalescing

> Attackers can cause denial of service in Tornado web framework by sending crafted HTTP requests that trigger quadratic time complexity in header processing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** AZL-72368, AZL-72374, BELL-CVE-2025-67725, DEBIAN-CVE-2025-67725, ECHO-55f5-3cd1-92e2, GHSA-c98p-7wgm-6p64, MINI-fghc-hmxg-cmjj, MINI-x787-x96m-j655, OESA-2026-1130, PYSEC-2025-266, UBUNTU-CVE-2025-67725

## What is CVE-2025-67725?

CVE-2025-67725 is a high-severity denial of service vulnerability in tornadoweb tornado, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado is a Python web framework and asynchronous networking library. In versions 6.5.2 and below, a single maliciously crafted HTTP request can block the server's event loop for an extended period, caused by the HTTPHeaders.add method. The function accumulates values using string concatenation when the same header name is repeated, causing a Denial of Service (DoS).  Due to Python string immutability, each concatenation copies the entire string, resulting in O(n²) time complexity. The severity can vary from high if max_header_size has been increased from its default, to low if it has its default value of 64KB. This issue is fixed in version 6.5.3.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-67725?

3 open source packages ship an affected version, including tornado. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.5.3 |
| `tornado` | PyPI | All versions | 6.5.3 |
| `tornado` | PyPI | All versions | 6.5.3 |

Products: Tornadoweb Tornado.

## How do I fix CVE-2025-67725?

Upgrade tornado to 6.5.3 or later.

## Is CVE-2025-67725 being exploited?

There is no known exploitation of CVE-2025-67725 in the wild and no public exploit code.

## Other vulnerabilities in tornadoweb tornado

- [CVE-2026-31958](https://insights.sbomify.com/CVE-2026-31958/): Tornado has a DoS due to too many multipart parts (high 8.7)
- [CVE-2025-67726](https://insights.sbomify.com/CVE-2025-67726/): Tornado is Vulnerable to Quadratic DoS via Crafted Multipart Parameters (high 7.5)
- [CVE-2024-52804](https://insights.sbomify.com/CVE-2024-52804/): Tornado has HTTP cookie parsing DoS vulnerability (high 7.5)
- [CVE-2026-35536](https://insights.sbomify.com/CVE-2026-35536/): Tornado has incomplete validation of cookie attributes (high 7.2)
- [CVE-2014-9720](https://insights.sbomify.com/CVE-2014-9720/): Tornado XSRF cookie allows side-channel attack against TLS (BREACH attack) (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67725 and fix it if it is affected.

What it is: CVE-2025-67725 is a high-severity denial of service vulnerability in tornadoweb tornado, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67725 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.5.3
- tornado (PyPI): affected all versions; fixed in 6.5.3
- tornado (PyPI): affected all versions; fixed in 6.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67725/ (Markdown: https://insights.sbomify.com/CVE-2025-67725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67725
- OSV: https://osv.dev/vulnerability/CVE-2025-67725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67725/
Summaries are generated and may contain mistakes; the official description above is the record.
