# CVE-2025-67727: Parse Server GitHub CI workflow vulnerable to RCE through Improper Privilege Management

> Attackers can execute arbitrary code and escalate privileges in Parse Server's GitHub CI workflow by exploiting improper privilege management in forked repositories.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 12 Dec 2025
- **Also known as:** BIT-parse-2025-67727, GHSA-6w8g-mgvv-3fcj

## What is CVE-2025-67727?

CVE-2025-67727 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that runs Node.js. In versions prior to 8.6.0-alpha.2, a GitHub CI workflow is triggered in a way that grants the GitHub Actions workflow elevated permissions, giving it access to GitHub secrets and write permissions which are defined in the workflow. Code from a fork or lifecycle scripts is potentially included. Only the repository's CI/CD infrastructure is affected, including any public GitHub forks with GitHub Actions enabled. This issue is fixed version 8.6.0-alpha.2 and commits 6b9f896 and e3d27fe.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-67727?

1 open source package ship an affected version, including parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | All versions | 8.6.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2025-67727?

Upgrade parse to 8.6.0 or later.

## Is CVE-2025-67727 being exploited?

There is no known exploitation of CVE-2025-67727 in the wild and no public exploit code.

Public exploit code:

- Lab reproducing CVE-2025-67727 (parse-community/parse-server ci-performance.yml pull_request_target RCE at e78e58d) — authorized security research (github_poc): https://github.com/pvharmo2/gha-lab-51c6b6d0a0

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67727 and fix it if it is affected.

What it is: CVE-2025-67727 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67727 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected all versions; fixed in 8.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67727/ (Markdown: https://insights.sbomify.com/CVE-2025-67727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67727
- OSV: https://osv.dev/vulnerability/CVE-2025-67727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67727/
Summaries are generated and may contain mistakes; the official description above is the record.
