{"answers":{"affected":"3 open source packages ship an affected version, including lmdeploy. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67729 exists.","fix":"Upgrade lmdeploy to 0.11.1 or later.","what":"CVE-2025-67729 is a high-severity unsafe deserialization vulnerability in InternLM lmdeploy, published on 26 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-67729 and fix it if it is affected.\n\nWhat it is: CVE-2025-67729 is a high-severity unsafe deserialization vulnerability in InternLM lmdeploy, published on 26 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67729 exists.\n\nAffected packages and fixed versions:\n- lmdeploy (PyPI): affected all versions; fixed in 0.11.1\n- lmdeploy (PyPI): affected all versions; fixed in 0.11.1\n- lmdeploy (PyPI): affected all versions; fixed in 0.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67729/ (Markdown: https://insights.sbomify.com/CVE-2025-67729/index.md)","id":"CVE-2025-67729","markdown":"https://insights.sbomify.com/CVE-2025-67729/index.md","name":"CVE-2025-67729","record":{"aliases":["GHSA-9pf3-7rrr-x5jh","PYSEC-2026-1578"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM deployment toolkit","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into loading malicious model files due to insecure deserialization in LMDeploy.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lmdeploy","vendor":"internlm"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy where torch.load() is called without the weights_only=True parameter when loading model checkpoint files. This allows an attacker to execute arbitrary code on the victim's machine when they load a malicious .bin or .pt model file. This issue has been patched in version 0.11.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load()","id":"CVE-2025-67729","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Frappe authenticated users can execute XSS through form description fields","id":"CVE-2025-67730"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"lmdeploy","purl":null,"source":"GHSA-9pf3-7rrr-x5jh"},{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"lmdeploy","purl":"pkg:pypi/lmdeploy","source":"GHSA-9pf3-7rrr-x5jh"},{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"lmdeploy","purl":"pkg:pypi/lmdeploy","source":"PYSEC-2026-1578"}],"prev":{"headline":"Fireshare Public Uploads feature is vulnerable to OS Command Injection (RCE)","id":"CVE-2025-67728"},"products":["lmdeploy"],"published":"2025-12-26","related":[{"cvss_score":7.7,"headline":"LMDeploy Server-Side Request Forgery via HTTP Redirect Bypass","id":"CVE-2026-63764","kev_date_added":null,"published":"2026-07-21"},{"cvss_score":7.5,"headline":"LMDeploy Vulnerable to Server-Side Request Forgery (SSRF) via Vision-Language Image Loading","id":"CVE-2026-33626","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":4.8,"headline":"InternLM LMDeploy PT File utils.py load_weight_ckpt deserialization","id":"CVE-2025-3162","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":4.8,"headline":"InternLM LMDeploy conf.py open code injection","id":"CVE-2025-3163","kev_date_added":null,"published":"2025-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-26","vendors":["InternLM"]},"summary":"Attackers can execute arbitrary code by tricking users into loading malicious model files due to insecure deserialization in LMDeploy.","url":"https://insights.sbomify.com/CVE-2025-67729/"}