# CVE-2025-67729: lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load()

> Attackers can execute arbitrary code by tricking users into loading malicious model files due to insecure deserialization in LMDeploy.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Dec 2025
- **Updated:** 26 Dec 2025
- **Also known as:** GHSA-9pf3-7rrr-x5jh, PYSEC-2026-1578

## What is CVE-2025-67729?

CVE-2025-67729 is a high-severity unsafe deserialization vulnerability in InternLM lmdeploy, published on 26 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy where torch.load() is called without the weights_only=True parameter when loading model checkpoint files. This allows an attacker to execute arbitrary code on the victim's machine when they load a malicious .bin or .pt model file. This issue has been patched in version 0.11.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-67729?

3 open source packages ship an affected version, including lmdeploy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lmdeploy` | PyPI | All versions | 0.11.1 |
| `lmdeploy` | PyPI | All versions | 0.11.1 |
| `lmdeploy` | PyPI | All versions | 0.11.1 |

Products: Internlm Lmdeploy.

## How do I fix CVE-2025-67729?

Upgrade lmdeploy to 0.11.1 or later.

## Is CVE-2025-67729 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67729 exists.

## Other vulnerabilities in InternLM lmdeploy

- [CVE-2026-63764](https://insights.sbomify.com/CVE-2026-63764/): LMDeploy Server-Side Request Forgery via HTTP Redirect Bypass (high 7.7)
- [CVE-2026-33626](https://insights.sbomify.com/CVE-2026-33626/): LMDeploy Vulnerable to Server-Side Request Forgery (SSRF) via Vision-Language Image Loading (high 7.5)
- [CVE-2025-3162](https://insights.sbomify.com/CVE-2025-3162/): InternLM LMDeploy PT File utils.py load_weight_ckpt deserialization (medium 4.8)
- [CVE-2025-3163](https://insights.sbomify.com/CVE-2025-3163/): InternLM LMDeploy conf.py open code injection (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67729 and fix it if it is affected.

What it is: CVE-2025-67729 is a high-severity unsafe deserialization vulnerability in InternLM lmdeploy, published on 26 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67729 exists.

Affected packages and fixed versions:
- lmdeploy (PyPI): affected all versions; fixed in 0.11.1
- lmdeploy (PyPI): affected all versions; fixed in 0.11.1
- lmdeploy (PyPI): affected all versions; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67729/ (Markdown: https://insights.sbomify.com/CVE-2025-67729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67729
- OSV: https://osv.dev/vulnerability/CVE-2025-67729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67729/
Summaries are generated and may contain mistakes; the official description above is the record.
