# CVE-2025-6773: HKUDS LightRAG File Upload document_routes.py upload_to_input_dir path traversal

> Attackers can exploit a path traversal vulnerability in the file upload function to read or modify arbitrary files on the local host.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2025
- **Updated:** 27 Jun 2025
- **Also known as:** GHSA-v9w6-9hq9-33ch, PYSEC-2026-1539

## What is CVE-2025-6773?

CVE-2025-6773 is a medium-severity path traversal vulnerability in HKUDS LightRAG, published on 27 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in HKUDS LightRAG up to 1.3.8. It has been declared as critical. Affected by this vulnerability is the function upload_to_input_dir of the file lightrag/api/routers/document_routes.py of the component File Upload. The manipulation of the argument file.filename leads to path traversal. It is possible to launch the attack on the local host. The identifier of the patch is 60777d535b719631680bcf5d0969bdef79ca4eaf. It is recommended to apply a patch to fix this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-6773?

3 open source packages ship an affected version, including lightrag-hku.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightrag-hku` | PyPI | All versions | 1.3.8 |
| `lightrag-hku` | PyPI | All versions | 1.3.8 |
| `lightrag-hku` | PyPI | All versions | 1.3.8 |

## How do I fix CVE-2025-6773?

Upgrade lightrag-hku to 1.3.8 or later.

## Is CVE-2025-6773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6773 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6773 and fix it if it is affected.

What it is: CVE-2025-6773 is a medium-severity path traversal vulnerability in HKUDS LightRAG, published on 27 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6773 exists.

Affected packages and fixed versions:
- lightrag-hku (PyPI): affected all versions; fixed in 1.3.8
- lightrag-hku (PyPI): affected all versions; fixed in 1.3.8
- lightrag-hku (PyPI): affected all versions; fixed in 1.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6773/ (Markdown: https://insights.sbomify.com/CVE-2025-6773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6773
- OSV: https://osv.dev/vulnerability/CVE-2025-6773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6773/
Summaries are generated and may contain mistakes; the official description above is the record.
