{"answers":{"affected":"2 open source packages ship an affected version, including servify-express. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-67731 in the wild and no public exploit code.","fix":"Upgrade servify-express to 1.2 or later.","what":"CVE-2025-67731 is a high-severity denial of service vulnerability in Aarondoran servify-express, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-67731 and fix it if it is affected.\n\nWhat it is: CVE-2025-67731 is a high-severity denial of service vulnerability in Aarondoran servify-express, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-67731 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- servify-express (npm): affected all versions; fixed in 1.2\n- servify-express (npm): affected all versions; fixed in 1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67731/ (Markdown: https://insights.sbomify.com/CVE-2025-67731/index.md)","id":"CVE-2025-67731","markdown":"https://insights.sbomify.com/CVE-2025-67731/index.md","name":"CVE-2025-67731","record":{"aliases":["GHSA-qgc4-8p88-4w7m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Express wrapper","requires_auth":"none","summary":"Attackers can cause denial of service by sending large JSON payloads to applications using this Node.js package, leading to memory exhaustion or crashes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"servify_express","vendor":"servify-express.js"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Servify Express is a Node.js package to start an Express server and log the port it's running on. Prior to 1.2, the Express server used express.json() without a size limit, which could allow attackers to send extremely large request bodies. This can cause excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser without limits and exposed to untrusted clients is affected. The issue is not a flaw in Express itself, but in configuration. This issue is fixed in version 1.2. To work around, consider adding a limit option to the JSON parser, rate limiting at the application or reverse-proxy level, rejecting unusually large requests before parsing, or using a reverse proxy (such as NGINX) to enforce maximum request body sizes.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Servify Express does not enforce rate limiting when parsing JSON","id":"CVE-2025-67731","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Dify Vulnerable to Plaintext API Key Exposure via Model Provider Configuration Endpoint","id":"CVE-2025-67732"},"packages":[{"ecosystem":"npm","fixed":["1.2"],"introduced":["0"],"last_affected":[],"package":"servify-express","purl":null,"source":"GHSA-qgc4-8p88-4w7m"},{"ecosystem":"npm","fixed":["1.2"],"introduced":["0"],"last_affected":[],"package":"servify-express","purl":"pkg:npm/servify-express","source":"GHSA-qgc4-8p88-4w7m"}],"prev":{"headline":"Frappe authenticated users can execute XSS through form description fields","id":"CVE-2025-67730"},"products":["servify-express"],"published":"2025-12-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-12","vendors":["Aarondoran"]},"summary":"Attackers can cause denial of service by sending large JSON payloads to applications using this Node.js package, leading to memory exhaustion or crashes.","url":"https://insights.sbomify.com/CVE-2025-67731/"}