CVE-2025-67733 Valkey Affected by RESP Protocol Injection via Lua error_reply

High 8.5 Published Updated

Attackers can inject arbitrary data into client responses via Lua script error handling, potentially corrupting or tampering with data returned to other users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-67733?

CVE-2025-67733 is a high-severity vulnerability in valkey-io valkey, published on 23 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Valkey is a distributed key-value database. Prior to versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12, a malicious user can use scripting commands to inject arbitrary information into the response stream for the given client, potentially corrupting or returning tampered data to other users on the same connection. The error handling code for lua scripts does not properly handle null characters. Versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12 fix the issue.

Weakness: CWE-170, CWE-74

Which versions are affected by CVE-2025-67733?

1 open source package ship an affected version, including valkey. It affects 1 product.

PackageAffectedFixed in
valkey BitnamiAll versions7.2.12, 8.0.7, 8.1.6, 9.0.2

Products include Lfprojects Valkey.

How do I fix CVE-2025-67733?

Upgrade valkey to a fixed version for your release line: 7.2.12, 8.0.7, 8.1.6 or 9.0.2.

Is CVE-2025-67733 being exploited?

There is no known exploitation of CVE-2025-67733 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as ALPINE-CVE-2025-67733, AZL-78317, BELL-CVE-2025-67733, BIT-valkey-2025-67733, DEBIAN-CVE-2025-67733, GHSA-p876-p7q5-hv2m and 2 more.

Is CVE-2025-67733 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free