CVE-2025-67735 Netty has a CRLF Injection vulnerability in io.netty.handler.codec.http.HttpRequestEncoder
Attackers can perform HTTP request smuggling via CRLF injection in Netty's HttpRequestEncoder, affecting applications using this library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-67735?
CVE-2025-67735 is a medium-severity vulnerability in Netty Netty, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.
Weakness: CWE-93
Which versions are affected by CVE-2025-67735?
4 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-codec-http Maven | All versions | 4.1.129.Final |
io.netty:netty-codec-http Maven | All versions | 4.1.129.Final |
io.netty:netty-codec-http Maven | From 4.2.0.Alpha1 | 4.2.8.Final |
io.netty:netty-codec-http Maven | From 4.2.0.Alpha1 | 4.2.8.Final |
Linux distribution packages (3)
netty SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.1.130-150200.4.40.1 |
netty openSUSE:Leap 15.6 | All versions | 4.1.130-150200.4.40.1 |
netty openSUSE:Tumbleweed | All versions | 4.1.130-1.1 |
Products include Netty Netty.
How do I fix CVE-2025-67735?
Upgrade io.netty:netty-codec-http to a fixed version for your release line: 4.1.129.Final or 4.2.8.Final.
Is CVE-2025-67735 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67735 exists.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as CLEANSTART-2026-CE96605, CLEANSTART-2026-EA68538, CLEANSTART-2026-QD78473, CLEANSTART-2026-YX43622, CLSA-2026-1777941815, CLSA-2026-1792688648 and 69 more.