# CVE-2025-67735: Netty has a CRLF Injection vulnerability in io.netty.handler.codec.http.HttpRequestEncoder

> Attackers can perform HTTP request smuggling via CRLF injection in Netty's HttpRequestEncoder, affecting applications using this library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2025
- **Updated:** 16 Dec 2025
- **Also known as:** CLEANSTART-2026-CE96605, CLEANSTART-2026-EA68538, CLEANSTART-2026-QD78473, CLEANSTART-2026-YX43622, CLSA-2026-1777941815, CLSA-2026-1792688648, DEBIAN-CVE-2025-67735, ECHO-a5b0-7bf4-eb62, GHSA-84h7-rjj3-6jx4, MINI-28f5-j56w-xx72, MINI-29pm-5grp-93j6, MINI-34px-6jcv-h975, MINI-35f5-rr26-33mq, MINI-3fxj-qcp7-xq6m, MINI-3rw8-r982-8v3j, MINI-47xm-ghf3-hgpp, MINI-4c6h-7fqg-2vpx, MINI-4jq4-wfxg-gxfv, MINI-52gc-3823-39hx, MINI-579g-5vw3-3hg5, MINI-59gr-c33p-g9p2, MINI-5wqh-r5vw-6pvm, MINI-6cfm-qpmm-7wpm, MINI-6p6h-vjrc-328q, MINI-73pv-6j82-jgqg, MINI-88c9-5g25-hhqm, MINI-8hr2-4vv3-7v5h, MINI-935m-jvj5-vcgx, MINI-9v2j-cjxp-xm2p, MINI-c9jg-49v6-q382, MINI-f4c3-2wvq-f764, MINI-f6c2-cjph-pm93, MINI-fh92-fcc2-258v, MINI-fjwg-vhmh-8cp3, MINI-fqp8-56gw-55mf, MINI-fvr2-hv3x-8mqr, MINI-fvww-8963-w4p7, MINI-fwjw-36pm-m4jp, MINI-fxfh-mjvq-7h27, MINI-g336-92cv-53qm, MINI-ghvr-r6vc-23f8, MINI-h7gq-3cx5-3vcm, MINI-h7x3-cwjg-2j4x, MINI-hmmm-x9vr-8whv, MINI-hv4v-5hm8-3f2x, MINI-hw52-m64r-g94v, MINI-j2m6-q42q-r4rf, MINI-m5q6-m5x7-7p28, MINI-mmcr-59xf-f683, MINI-mv8q-352r-4x87, MINI-p74m-45pq-wqhv, MINI-p78f-hwjr-fvqr, MINI-pgwq-p3ch-7gp5, MINI-q4vm-2hj7-64rg, MINI-qfv4-44w2-67mg, MINI-qgmm-8j39-m7xr, MINI-qmxm-g69x-9fp3, MINI-qxc3-c3j2-v9c8, MINI-r78q-8h6g-hq23, MINI-rmrc-fxr5-8wgx, MINI-rr29-25m5-99cw, MINI-rxfr-mwwc-m2mf, MINI-v9p9-2jgr-wvgq, MINI-vr76-5gpx-hf68, MINI-vv6g-jhvw-3j5j, MINI-wrg5-3gx5-hmm3, MINI-wrp8-52vj-88hr, MINI-x3rf-pxg2-4xm6, MINI-x4c5-vppw-v8xq, MINI-xg6v-v9g9-x547, MINI-xp73-3792-ffh8, ROOT-APP-MAVEN-CVE-2025-67735, SUSE-SU-2025:4489-1, UBUNTU-CVE-2025-67735, openSUSE-SU-2025:15824-1

## What is CVE-2025-67735?

CVE-2025-67735 is a medium-severity vulnerability in Netty Netty, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2025-67735?

4 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.129.Final |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.129.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Alpha1 | 4.2.8.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Alpha1 | 4.2.8.Final |
| `netty` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.1.130-150200.4.40.1 |
| `netty` | openSUSE:Leap 15.6 | All versions | 4.1.130-150200.4.40.1 |
| `netty` | openSUSE:Tumbleweed | All versions | 4.1.130-1.1 |

Products: Netty Netty.

## How do I fix CVE-2025-67735?

Upgrade io.netty:netty-codec-http to a fixed version for your release line: 4.1.129.Final or 4.2.8.Final.

## Is CVE-2025-67735 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67735 exists.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67735 and fix it if it is affected.

What it is: CVE-2025-67735 is a medium-severity vulnerability in Netty Netty, published on 16 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-67735 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.129.Final
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.129.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.8.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.8.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67735/ (Markdown: https://insights.sbomify.com/CVE-2025-67735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67735
- OSV: https://osv.dev/vulnerability/CVE-2025-67735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67735/
Summaries are generated and may contain mistakes; the official description above is the record.
