CVE-2025-67746 Composer vulnerable to ANSI sequence injection
Attackers can inject ANSI control characters into Composer terminal output, causing display corruption or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-67746?
CVE-2025-67746 is a low-severity vulnerability in composer, published on 30 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Weakness: CWE-74
Which versions are affected by CVE-2025-67746?
5 open source packages ship an affected version, including composer/composer and composer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
composer/composer Packagist | From 2.0.0 | 2.2.26 |
composer/composer Packagist | From 2.0.0 | 2.2.26 |
composer/composer Packagist | From 2.3.0 | 2.9.3 |
composer/composer Packagist | From 2.3.0 | 2.9.3 |
composer Bitnami | From 2.0.0 | 2.2.26, 2.9.3 |
Linux distribution packages (3)
php-composer2 SUSE:Linux Enterprise Module for Web and Scripting 15 SP7 | All versions | 2.6.4-150600.3.6.1 |
php-composer2 openSUSE:Leap 15.6 | All versions | 2.6.4-150600.3.6.1 |
php-composer2 openSUSE:Tumbleweed | All versions | 2.9.3-1.1 |
Products include Getcomposer Composer.
How do I fix CVE-2025-67746?
Upgrade composer/composer to a fixed version for your release line: 2.2.26 or 2.9.3.
Is CVE-2025-67746 being exploited?
There is no known exploitation of CVE-2025-67746 in the wild and no public exploit code.
Other vulnerabilities in composer
- CVE-2026-40261 Composer has Command Injection via Malicious Perforce Reference
- CVE-2024-24821 Code execution and possible privilege escalation via compromised InstalledVersions.php or installed.php in Composer
- CVE-2015-8371 Composer allows cache poisoning from other projects built on the same host
- CVE-2021-41116 Command injection in composer on Windows
- CVE-2026-40176 Composer is vulnerable to Command Injection via Malicious Perforce Repository
Sources
Also known as BIT-composer-2025-67746, DEBIAN-CVE-2025-67746, GHSA-59pp-r3rg-353g, MINI-9q6x-466p-7x6x, MINI-gj2r-342r-cpvq, SUSE-SU-2026:0825-1 and 2 more.