CVE-2025-67750 Lightning Flow Scanner is Vulnerable to Code Injection via Unsafe Use of new Function() in APIVersion Rule

High 8.4 Published Updated

Attackers can execute arbitrary JavaScript on developer machines or CI runners by crafting malicious Salesforce Flow metadata files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-67750?

CVE-2025-67750 is a high-severity code injection vulnerability in lightning-flow-scanner, published on 12 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Lightning Flow Scanner provides a A CLI plugin, VS Code Extension and GitHub Action for analysis and optimization of Salesforce Flows. Versions 6.10.5 and below allow a maliciously crafted flow metadata file to cause arbitrary JavaScript execution during scanning. The APIVersion rule uses new Function() to evaluate expression strings, enabling an attacker to supply a malicious expression within rule configuration or crafted flow metadata. This could compromise developer machines, CI runners, or editor environments. This issue is fixed in version 6.10.6.

Weakness: CWE-94

Which versions are affected by CVE-2025-67750?

2 open source packages ship an affected version, including lightning-flow-scanner.

PackageAffectedFixed in
lightning-flow-scanner npmAll versions6.10.6
lightning-flow-scanner npmAll versions6.10.6

How do I fix CVE-2025-67750?

Upgrade lightning-flow-scanner to 6.10.6 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-67750 being exploited?

There is no known exploitation of CVE-2025-67750 in the wild and no public exploit code.

Sources

Also known as GHSA-55jh-84jv-8mx8.

Is CVE-2025-67750 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free