{"answers":{"affected":"2 open source packages ship an affected version, including lightning-flow-scanner.","exploited":"There is no known exploitation of CVE-2025-67750 in the wild and no public exploit code.","fix":"Upgrade lightning-flow-scanner to 6.10.6 or later.","what":"CVE-2025-67750 is a high-severity code injection vulnerability in lightning-flow-scanner, published on 12 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-67750 and fix it if it is affected.\n\nWhat it is: CVE-2025-67750 is a high-severity code injection vulnerability in lightning-flow-scanner, published on 12 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-67750 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lightning-flow-scanner (npm): affected all versions; fixed in 6.10.6\n- lightning-flow-scanner (npm): affected all versions; fixed in 6.10.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-67750/ (Markdown: https://insights.sbomify.com/CVE-2025-67750/index.md)","id":"CVE-2025-67750","markdown":"https://insights.sbomify.com/CVE-2025-67750/index.md","name":"CVE-2025-67750","record":{"aliases":["GHSA-55jh-84jv-8mx8"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Salesforce Flow Scanner","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript on developer machines or CI runners by crafting malicious Salesforce Flow metadata files.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Lightning Flow Scanner provides a A CLI plugin, VS Code Extension and GitHub Action for analysis and optimization of Salesforce Flows. Versions 6.10.5 and below allow a maliciously crafted flow metadata file to cause arbitrary JavaScript execution during scanning. The APIVersion rule uses new Function() to evaluate expression strings, enabling an attacker to supply a malicious expression within rule configuration or crafted flow metadata. This could compromise developer machines, CI runners, or editor environments. This issue is fixed in version 6.10.6.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Lightning Flow Scanner is Vulnerable to Code Injection via Unsafe Use of new Function() in APIVersion Rule","id":"CVE-2025-67750","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"ChurchCRM has SQL Injection in Event Editor via `EN_tyid` Parameter caused by an Incomplete Fix","id":"CVE-2025-67751"},"packages":[{"ecosystem":"npm","fixed":["6.10.6"],"introduced":["0"],"last_affected":[],"package":"lightning-flow-scanner","purl":null,"source":"GHSA-55jh-84jv-8mx8"},{"ecosystem":"npm","fixed":["6.10.6"],"introduced":["0"],"last_affected":[],"package":"lightning-flow-scanner","purl":"pkg:npm/lightning-flow-scanner","source":"GHSA-55jh-84jv-8mx8"}],"prev":{"headline":"PCSX2 has an Out-of-bounds Read due to unchecked offset and size passed to memcpy","id":"CVE-2025-67749"},"products":["lightning-flow-scanner"],"published":"2025-12-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-12","vendors":["Flow-Scanner"]},"summary":"Attackers can execute arbitrary JavaScript on developer machines or CI runners by crafting malicious Salesforce Flow metadata files.","url":"https://insights.sbomify.com/CVE-2025-67750/"}