# CVE-2025-67750: Lightning Flow Scanner is Vulnerable to Code Injection via Unsafe Use of new Function() in APIVersion Rule

> Attackers can execute arbitrary JavaScript on developer machines or CI runners by crafting malicious Salesforce Flow metadata files.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 12 Dec 2025
- **Also known as:** GHSA-55jh-84jv-8mx8

## What is CVE-2025-67750?

CVE-2025-67750 is a high-severity code injection vulnerability in lightning-flow-scanner, published on 12 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Lightning Flow Scanner provides a A CLI plugin, VS Code Extension and GitHub Action for analysis and optimization of Salesforce Flows. Versions 6.10.5 and below allow a maliciously crafted flow metadata file to cause arbitrary JavaScript execution during scanning. The APIVersion rule uses new Function() to evaluate expression strings, enabling an attacker to supply a malicious expression within rule configuration or crafted flow metadata. This could compromise developer machines, CI runners, or editor environments. This issue is fixed in version 6.10.6.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-67750?

2 open source packages ship an affected version, including lightning-flow-scanner.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightning-flow-scanner` | npm | All versions | 6.10.6 |
| `lightning-flow-scanner` | npm | All versions | 6.10.6 |

## How do I fix CVE-2025-67750?

Upgrade lightning-flow-scanner to 6.10.6 or later.

## Is CVE-2025-67750 being exploited?

There is no known exploitation of CVE-2025-67750 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67750 and fix it if it is affected.

What it is: CVE-2025-67750 is a high-severity code injection vulnerability in lightning-flow-scanner, published on 12 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67750 in the wild and no public exploit code.

Affected packages and fixed versions:
- lightning-flow-scanner (npm): affected all versions; fixed in 6.10.6
- lightning-flow-scanner (npm): affected all versions; fixed in 6.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67750/ (Markdown: https://insights.sbomify.com/CVE-2025-67750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67750
- OSV: https://osv.dev/vulnerability/CVE-2025-67750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67750/
Summaries are generated and may contain mistakes; the official description above is the record.
