# CVE-2025-67796: IKUS Rdiffweb allows an attacker with any valid or stolen access token to act as other users

> Attackers with valid tokens can access or modify other users' data due to missing authorization checks in the API.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 5 May 2026
- **Also known as:** GHSA-v4gp-hf5j-4566, PYSEC-2026-3048

## What is CVE-2025-67796?

CVE-2025-67796 is a high-severity missing authorization vulnerability in n/a, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

IKUS Rdiffweb before 2.10.5 has an improper authorization flaw that allows an attacker with any valid or stolen access token to act as other users. The API does not enforce binding between the authenticated subject and the targeted user/tenant, so crafted requests can read or modify other users data and, in some cases, perform privileged actions. This issue may enable cross-tenant access. Fixed in version 2.10.6.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-67796?

3 open source packages ship an affected version, including rdiffweb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rdiffweb` | PyPI | All versions | 2.10.6 |
| `rdiffweb` | PyPI | All versions | 2.10.6 |
| `rdiffweb` | PyPI | All versions | 2.10.6 |

## How do I fix CVE-2025-67796?

Upgrade rdiffweb to 2.10.6 or later.

## Is CVE-2025-67796 being exploited?

There is no known exploitation of CVE-2025-67796 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67796 and fix it if it is affected.

What it is: CVE-2025-67796 is a high-severity missing authorization vulnerability in n/a, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67796 in the wild and no public exploit code.

Affected packages and fixed versions:
- rdiffweb (PyPI): affected all versions; fixed in 2.10.6
- rdiffweb (PyPI): affected all versions; fixed in 2.10.6
- rdiffweb (PyPI): affected all versions; fixed in 2.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67796/ (Markdown: https://insights.sbomify.com/CVE-2025-67796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67796
- OSV: https://osv.dev/vulnerability/CVE-2025-67796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67796/
Summaries are generated and may contain mistakes; the official description above is the record.
