CVE-2025-67818 Weaviate OSS has a Path Traversal Vulnerability via Backup ZipSlip
An attacker with data insertion privileges can use path traversal in backup names to overwrite arbitrary files during restoration, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-67818?
CVE-2025-67818 is a high-severity path traversal vulnerability in n/a, published on 12 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in Weaviate OSS before 1.33.4. An attacker with access to insert data into the database can craft an entry name with an absolute path (e.g., /etc/...) or use parent directory traversal (../../..) to escape the restore root when a backup is restored, potentially creating or overwriting files in arbitrary locations within the application's privilege scope.
Weakness: CWE-22
Which versions are affected by CVE-2025-67818?
9 open source packages ship an affected version, including github.com/weaviate/weaviate. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/weaviate/weaviate Go | All versions | 1.30.20, 1.31.19, 1.32.16, 1.33.4 |
github.com/weaviate/weaviate Go | All versions | 1.30.20 |
github.com/weaviate/weaviate Go | All versions | 1.30.20 |
github.com/weaviate/weaviate Go | From 1.31.0-rc.0 | 1.31.19 |
github.com/weaviate/weaviate Go | From 1.31.0-rc.0 | 1.31.19 |
github.com/weaviate/weaviate Go | From 1.32.0-rc.0 | 1.32.16 |
3 more packages
github.com/weaviate/weaviate Go | From 1.32.0-rc.0 | 1.32.16 |
github.com/weaviate/weaviate Go | From 1.33.0-rc.0 | 1.33.4 |
github.com/weaviate/weaviate Go | From 1.33.0-rc.0 | 1.33.4 |
Products include Weaviate Weaviate.
How do I fix CVE-2025-67818?
Upgrade github.com/weaviate/weaviate to a fixed version for your release line: 1.30.20, 1.31.19, 1.32.16 or 1.33.4.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-67818 being exploited?
There is no known exploitation of CVE-2025-67818 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-7v39-2hx7-7c43, GO-2025-4237, MINI-5h4j-mp8v-93v2, MINI-8mm4-g48r-464f, MINI-c2fr-jfgr-9w2r, MINI-g9xw-w665-87cw and 4 more.