# CVE-2025-67819: Weaviate OSS has path traversal vulnerability via the Shard Movement API

> An attacker can read arbitrary files from the server by exploiting a lack of validation in the file transfer logic when specific replication states are active.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 12 Dec 2025
- **Also known as:** GHSA-hmmh-292h-3364, GO-2025-4238, MINI-3rpf-m9x3-6g34, MINI-4xwj-q4m8-chv6, MINI-7mvr-mrfc-mh3j, MINI-j6x5-v68m-rrwq, MINI-v75c-hw4x-6xj5, MINI-v7p4-5vc2-7gv6

## What is CVE-2025-67819?

CVE-2025-67819 is a medium-severity path traversal vulnerability in n/a, published on 12 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue was discovered in Weaviate OSS before 1.33.4. Due to a lack of validation of the fileName field in the transfer logic, an attacker who can call the GetFile method while a shard is in the "Pause file activity" state and the FileReplicationService is reachable can read arbitrary files accessible to the service process.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-67819?

9 open source packages ship an affected version, including github.com/weaviate/weaviate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/weaviate/weaviate` | Go | From 1.30.0 | 1.30.20, 1.31.19, 1.32.16, 1.33.4 |
| `github.com/weaviate/weaviate` | Go | From 1.30.0 | 1.30.20 |
| `github.com/weaviate/weaviate` | Go | From 1.30.0 | 1.30.20 |
| `github.com/weaviate/weaviate` | Go | From 1.31.0-rc.0 | 1.31.19 |
| `github.com/weaviate/weaviate` | Go | From 1.31.0-rc.0 | 1.31.19 |
| `github.com/weaviate/weaviate` | Go | From 1.32.0-rc.0 | 1.32.16 |
| `github.com/weaviate/weaviate` | Go | From 1.32.0-rc.0 | 1.32.16 |
| `github.com/weaviate/weaviate` | Go | From 1.33.0-rc.0 | 1.33.4 |
| `github.com/weaviate/weaviate` | Go | From 1.33.0-rc.0 | 1.33.4 |

Products: Weaviate Weaviate.

## How do I fix CVE-2025-67819?

Upgrade github.com/weaviate/weaviate to a fixed version for your release line: 1.30.20, 1.31.19, 1.32.16 or 1.33.4.

## Is CVE-2025-67819 being exploited?

There is no known exploitation of CVE-2025-67819 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-59093](https://insights.sbomify.com/CVE-2026-59093/): Weaviate < 1.38.0 - Privilege Escalation via Unchecked Permissions in RBAC Role Assignment (high 8.7)
- [CVE-2023-38976](https://insights.sbomify.com/CVE-2023-38976/): Weaviate denial of service vulnerability (high 7.5)
- [CVE-2025-67818](https://insights.sbomify.com/CVE-2025-67818/): Weaviate OSS has a Path Traversal Vulnerability via Backup ZipSlip (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67819 and fix it if it is affected.

What it is: CVE-2025-67819 is a medium-severity path traversal vulnerability in n/a, published on 12 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67819 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/weaviate/weaviate (Go): affected from 1.30.0; fixed in 1.30.20, 1.31.19, 1.32.16, 1.33.4
- github.com/weaviate/weaviate (Go): affected from 1.30.0; fixed in 1.30.20
- github.com/weaviate/weaviate (Go): affected from 1.30.0; fixed in 1.30.20
- github.com/weaviate/weaviate (Go): affected from 1.31.0-rc.0; fixed in 1.31.19
- github.com/weaviate/weaviate (Go): affected from 1.31.0-rc.0; fixed in 1.31.19
- github.com/weaviate/weaviate (Go): affected from 1.32.0-rc.0; fixed in 1.32.16
- github.com/weaviate/weaviate (Go): affected from 1.32.0-rc.0; fixed in 1.32.16
- github.com/weaviate/weaviate (Go): affected from 1.33.0-rc.0; fixed in 1.33.4
- github.com/weaviate/weaviate (Go): affected from 1.33.0-rc.0; fixed in 1.33.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67819/ (Markdown: https://insights.sbomify.com/CVE-2025-67819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67819
- OSV: https://osv.dev/vulnerability/CVE-2025-67819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67819/
Summaries are generated and may contain mistakes; the official description above is the record.
