CVE-2025-67847 Moodle: moodle: remote code execution via insufficient restore input validation
An attacker with restore interface access can execute arbitrary code on the server due to insufficient input validation in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-67847?
CVE-2025-67847 is a high-severity code injection vulnerability in Moodle Moodle, published on 23 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle. An attacker with access to the restore interface could trigger server-side execution of arbitrary code. This is due to insufficient validation of restore input, which leads to unintended interpretation by core restore routines. Successful exploitation could result in a full compromise of the Moodle application.
Weakness: CWE-94
Which versions are affected by CVE-2025-67847?
11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | From 4.2.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.2.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
5 more packages
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle Bitnami | All versions | 4.1.22, 4.4.12, 4.5.8, 5.0.4, 5.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2025-67847?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.22, 4.4.12, 4.5.8 or 5.0.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-67847 being exploited?
There is no known exploitation of CVE-2025-67847 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-67847, GHSA-xvmh-25jw-gmmm, UBUNTU-CVE-2025-67847.