# CVE-2025-67848: Moodle: moodle: authentication bypass via lti provider allows suspended users to gain unauthorized access.

> Suspended users can bypass authentication via LTI provider to gain unauthorized access and potentially disclose information in Moodle.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-moodle-2025-67848, GHSA-j5jv-w5cw-j9ff, UBUNTU-CVE-2025-67848

## What is CVE-2025-67848?

CVE-2025-67848 is a high-severity authentication bypass vulnerability in Moodle Moodle, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Moodle. This authentication bypass vulnerability allows suspended users to authenticate through the Learning Tools Interoperability (LTI) Provider. The issue arises from the LTI authentication handlers failing to enforce the user's suspension status, enabling unauthorized access to the system. This can lead to information disclosure or other unauthorized actions by users who should be restricted.

Weakness: CWE-280 (Improper Handling of Insufficient Permissions or Privileges)

## Which versions are affected by CVE-2025-67848?

11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.22 |
| `moodle/moodle` | Packagist | All versions | 4.1.22 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.12 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.12 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.8 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.8 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.4 |
| `moodle/moodle` | Packagist | From 5.0.0-beta | 5.0.4 |
| `moodle/moodle` | Packagist | From 5.1.0-beta | 5.1.1 |
| `moodle/moodle` | Packagist | From 5.1.0-beta | 5.1.1 |
| `moodle` | Bitnami | All versions | 4.1.22, 4.4.11, 4.5.8, 5.0.4, 5.1.1 |

Products: Moodle Moodle.

## How do I fix CVE-2025-67848?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.22, 4.4.12, 4.5.8 or 5.0.4.

## Is CVE-2025-67848 being exploited?

There is no known exploitation of CVE-2025-67848 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-67848 and fix it if it is affected.

What it is: CVE-2025-67848 is a high-severity authentication bypass vulnerability in Moodle Moodle, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-67848 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.22
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.22
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.12
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.12
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.8
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.8
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.4
- moodle/moodle (Packagist): affected from 5.0.0-beta; fixed in 5.0.4
- moodle/moodle (Packagist): affected from 5.1.0-beta; fixed in 5.1.1
- moodle/moodle (Packagist): affected from 5.1.0-beta; fixed in 5.1.1
- moodle (Bitnami): affected all versions; fixed in 4.1.22, 4.4.11, 4.5.8, 5.0.4, 5.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-67848/ (Markdown: https://insights.sbomify.com/CVE-2025-67848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-67848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-67848
- OSV: https://osv.dev/vulnerability/CVE-2025-67848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-67848/
Summaries are generated and may contain mistakes; the official description above is the record.
