CVE-2025-67850 Moodle: moodle: cross-site scripting vulnerability via inadequate input filtering in formula editor
Remote attackers can inject malicious scripts into Moodle's formula editor, executing code in other users' browsers to compromise data or perform unauthorized actions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67850?
CVE-2025-67850 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A flaw was found in moodle. This vulnerability, known as Cross-Site Scripting (XSS), occurs due to insufficient checks on user-provided data in the formula editor's arithmetic expression fields. A remote attacker could inject malicious code into these fields. When other users view these expressions, the malicious code would execute in their web browsers, potentially compromising their data or leading to unauthorized actions.
Weakness: CWE-79
Which versions are affected by CVE-2025-67850?
11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
5 more packages
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle Bitnami | All versions | 4.1.22, 4.4.11, 4.5.8, 5.0.4, 5.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2025-67850?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.22, 4.4.12, 4.5.8 or 5.0.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-67850 being exploited?
There is no known exploitation of CVE-2025-67850 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-67850, GHSA-6mmv-f6c6-v6q8, UBUNTU-CVE-2025-67850.