CVE-2025-67852 Moodle: moodle: open redirect vulnerability in oauth login flow allows redirection to malicious sites.
Remote attackers can redirect authenticated Moodle users to malicious sites via the OAuth login flow, facilitating phishing and information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67852?
CVE-2025-67852 is a low-severity vulnerability in Moodle Moodle, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A flaw was found in Moodle. An open redirect vulnerability in the OAuth login flow allows a remote attacker to redirect users to attacker-controlled pages after they have successfully authenticated. This occurs due to insufficient validation of redirect parameters, which could lead to phishing attacks or information disclosure.
Weakness: CWE-601
Which versions are affected by CVE-2025-67852?
11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
5 more packages
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle Bitnami | All versions | 4.1.22, 4.4.11, 4.5.8, 5.0.4, 5.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2025-67852?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.22, 4.4.12, 4.5.8 or 5.0.4.
Is CVE-2025-67852 being exploited?
There is no known exploitation of CVE-2025-67852 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-67852, GHSA-qv78-6gpp-hm68, UBUNTU-CVE-2025-67852.