CVE-2025-67855 Mooodle: mooodle: information disclosure and script execution via reflected cross-site scripting
Remote attackers can inject malicious scripts via crafted links in Moodle's policy tool, leading to information disclosure or client-side script execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67855?
CVE-2025-67855 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A flaw was found in mooodle. A remote attacker could exploit a reflected Cross-Site Scripting (XSS) vulnerability in the policy tool return URL. This vulnerability arises from insufficient sanitization of URL parameters, allowing attackers to inject malicious scripts through specially crafted links. Successful exploitation could lead to information disclosure or arbitrary client-side script execution within the user's browser.
Weakness: CWE-79
Which versions are affected by CVE-2025-67855?
11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
5 more packages
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle Bitnami | All versions | 4.1.22, 4.4.11, 4.5.8, 5.0.4, 5.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2025-67855?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.22, 4.4.12, 4.5.8 or 5.0.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-67855 being exploited?
There is no known exploitation of CVE-2025-67855 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-67855, GHSA-vwhw-vp9v-q9c9, UBUNTU-CVE-2025-67855.