CVE-2025-67857 Moodle: moodle: data exposure of user identifiers in urls
Attackers can view internal user IDs in URLs during anonymous submissions, compromising anonymity and exposing sensitive user data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-67857?
CVE-2025-67857 is a medium-severity vulnerability in Moodle Moodle, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A flaw was found in moodle. During anonymous assignment submissions, user identifiers were inadvertently exposed in URLs. This data exposure allows unauthorized viewers to see internal user IDs, compromising the intended anonymity and potentially leading to information disclosure.
Weakness: CWE-201
Which versions are affected by CVE-2025-67857?
11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | All versions | 4.1.22 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.12 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.8 |
5 more packages
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.0.0-beta | 5.0.4 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle/moodle Packagist | From 5.1.0-beta | 5.1.1 |
moodle Bitnami | All versions | 4.1.21, 4.4.11, 4.5.8, 5.0.4, 5.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2025-67857?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.22, 4.4.12, 4.5.8 or 5.0.4.
Is CVE-2025-67857 being exploited?
There is no known exploitation of CVE-2025-67857 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-67857, GHSA-8jrv-wx83-w3xj, UBUNTU-CVE-2025-67857.